root/branches/libffado-scons_porting_work/support/SConscript

Revision 519, 0.6 kB (checked in by arnonym, 14 years ago)

Add the first version of scons-support to ffado.

Everything seems to build correctly. Installing and library-versioning is not implemented yet.

[Hopefully this gets into the right branch.]

Line 
1 #! /usr/bin/env python
2
3 Import( 'env' )
4
5 env = env.Copy()
6
7 #env.AppendUnique( CPPPATH=["#/src"] )
8 #env.AppendUnique( LIBPATH=["#/src"] )
9 #env.AppendUnique( LIBS=["ffado"] )
10
11 #for app in ["test-ffado", "test-extplugcmd", "test-fw410", "test-volume", "test-mixer", "test-cycletimer", "test-timestampedbuffer", "test-ieee1394service", "test-streamdump"]:
12 #       env.Program( target=app, source = app+".cpp" )
13
14 #env.Program( target="test-ffado", source = "test-ffado.cpp" )
15 #env.Program( target="", source = ".cpp" )
16
17 #env.Program( target="test-sytmonitor", source = env.Split( "test-sytmonitor.cpp SytMonitor.cpp" ) )
18 #
19
20 env.SConscript( dirs="mixer", exports="env" )
21
Note: See TracBrowser for help on using the browser.