root/branches/libffado-scons_porting_work/support/mixer/SConscript

Revision 519, 383 bytes (checked in by arnonym, 15 years ago)

Add the first version of scons-support to ffado.

Everything seems to build correctly. Installing and library-versioning is not implemented yet.

[Hopefully this gets into the right branch.]

Line 
1 #! /usr/bin/env python
2
3 Import( 'env' )
4
5 env = env.Copy()
6
7 #env.AppendUnique( CPPPATH=["#/src"] )
8 #env.AppendUnique( LIBPATH=["#/src"] )
9 #env.AppendUnique( LIBS=["ffado"] )
10
11 for app in ["mixer_phase24.ui","mixer_phase88.ui"]:
12         #env.PyUIC( target=app.replace(".","")+".py", source=app )
13         env.Command( target=app.replace(".","")+".py", source=app, action="pyuic $SOURCE > $TARGET" )
14
15
Note: See TracBrowser for help on using the browser.