Changeset 1881

Show
Ignore:
Timestamp:
08/12/10 04:36:34 (11 years ago)
Author:
jwoithe
Message:

MOTU: include IDs for the Traveler Mk3 and 896HD Mk3 in the mixer and count these as generation-3 devices.

Files:

Legend:

Unmodified
Added
Removed
Modified
Copied
Moved
  • trunk/libffado/support/mixer-qt4/ffado/mixer/motu.py

    r1873 r1881  
    4040MOTU_MODEL_ULTRALITEmk3     = 0x0008 
    4141MOTU_MODEL_ULTRALITEmk3_HYB = 0x0009 
     42MOTU_MODEL_TRAVELERmk3      = 0x000a 
     43MOTU_MODEL_896HDmk3         = 0x000b 
    4244 
    4345class Motu(QWidget): 
     
    570572        # For the moment none of the "Mk3" (aka Generation-3) devices are 
    571573        # supported by ffado-mixer. 
    572         if (self.model==MOTU_MODEL_828mk3 or self.model==MOTU_MODEL_ULTRALITEmk3 or self.model==MOTU_MODEL_ULTRALITEmk3_HYB): 
     574        if (self.model==MOTU_MODEL_828mk3 or self.model==MOTU_MODEL_ULTRALITEmk3 or self.model==MOTU_MODEL_ULTRALITEmk3_HYB or self.model==MOTU_MODEL_TRAVELERmk3 or self.model==MOTU_MODEL_896HDmk3): 
    573575            log.debug("Generation-3 MOTU devices are not yet supported by ffado-mixer") 
    574576            return