Changeset 2176

Show
Ignore:
Timestamp:
07/06/12 04:34:04 (8 years ago)
Author:
jwoithe
Message:

When summarising the capability of the JACK package found on the system, spell out 'Jack Audio Connection Kit' in full in an attempt to avoid confusion with the CD ripping program 'jack' amongst new users.

Files:

Legend:

Unmodified
Added
Removed
Modified
Copied
Moved
  • trunk/libffado/SConstruct

    r2152 r2176  
    236236        if not(have_jack): 
    237237            print """ 
    238 No jack installed: assuming a FFADO setbuffersize-compatible version will be 
    239 used. 
     238No Jack Audio Connection Kit (JACK) installed: assuming a FFADO  
     239setbuffersize-compatible version will be used. 
    240240""" 
    241241        elif not(good_jack1 or good_jack2): 
    242242            FFADO_API_VERSION="8" 
    243243            print """ 
    244 Installed jack does not support FFADO setbuffersize API: will report earlier 
    245 API version at runtime.  Consider upgrading to jack1 >=0.122.0 or  
    246 jack2 >=1.9.9 at some point, and then recompile ffado to gain access to this 
    247 added feature. 
     244Installed Jack Audio Connection Kit (JACK) jack does not support FFADO  
     245setbuffersize API: will report earlier API version at runtime.  Consider  
     246upgrading to jack1 >=0.122.0 or jack2 >=1.9.9 at some point, and then  
     247recompile ffado to gain access to this added feature. 
    248248""" 
    249249        else: 
    250             print "Installed jack supports FFADO setbuffersize API" 
     250            print "Installed Jack Audio Connection Kit (JACK) supports FFADO setbuffersize API" 
    251251    elif env['ENABLE_SETBUFFERSIZE_API_VER'] == 'true': 
    252252        if (have_jack and not(good_jack1) and not(good_jack2)): 
    253253            print """ 
    254 SetBufferSize API version is enabled but no suitable version of jack has been 
    255 found.  The resulting FFADO would cause your jackd to abort with "incompatible 
    256 FFADO version".  Please upgrade to jack1 >=0.122.0 or jack2 >=1.9.9, or set 
    257 ENABLE_SETBUFFERSIZE_API_VER to "auto" or "false". 
     254SetBufferSize API version is enabled but no suitable version of Jack Audio  
     255Connection Kit (JACK) has been found.  The resulting FFADO would cause your  
     256jackd to abort with "incompatible FFADO version".  Please upgrade to  
     257jack1 >=0.122.0 or jack2 >=1.9.9, or set ENABLE_SETBUFFERSIZE_API_VER to "auto" 
     258or "false". 
    258259""" 
    259260            # Although it's not strictly an error, in almost every case that  
  • trunk/libffado/src/libieee1394/ieee1394service.cpp

    r2175 r2176  
    355355                m_have_read_ctr_and_clock = true; 
    356356        } 
     357//if (m_have_read_ctr_and_clock) 
     358//  Util::SystemTimeSource::setSource(CLOCK_REALTIME); 
    357359 
    358360        if (m_have_read_ctr_and_clock) {