Ticket #214 (closed bug: fixed)

Opened 6 years ago

Last modified 4 years ago

new scons issues warnings

Reported by: adi Assigned to:
Priority: trivial Milestone: FFADO 2.1
Component: Version: FFADO SVN (trunk)
Keywords: Cc:
The device the bug applies to:

Description

Running current scons from Debian Unstable produces these warnings:

adi@chopin:~/ffado/libffado$ scons
scons: Reading SConscript files ...

scons: warning: The Options class is deprecated; use the Variables class instead.
File "/home/adi/ffado/libffado/SConstruct", line 46, in <module>

scons: warning: The BoolOption() function is deprecated; use the BoolVariable() function instead.
File "/home/adi/ffado/libffado/SConstruct", line 55, in <module>

scons: warning: The PathOption() function is deprecated; use the PathVariable() function instead.
File "/home/adi/ffado/libffado/SConstruct", line 57, in <module>

scons: warning: The EnumOption() function is deprecated; use the EnumVariable() function instead.
File "/home/adi/ffado/libffado/SConstruct", line 82, in <module>

The attached patch seems to fix the issue, but I'm not common with scons.

Attachments

scons-fix.patch (5.3 kB) - added by adi on 04/16/09 03:45:30.

Change History

04/16/09 03:45:30 changed by adi

  • attachment scons-fix.patch added.

08/21/09 10:33:03 changed by arnonym

The problem with these warnings is: When the issues are fixed, the scripts won't run on older versions of scons like the one shipped in ubuntu-hardy (the last one with long-term-support).

There should be a way to disable these warnings in scons. I will have a look...

08/21/09 10:48:05 changed by das

Running scons with --warn=no-deprecated should do the trick. These warnings are annoying, but I don't think there's anything else one can do about it without breaking things elsewhere.

09/12/10 13:27:36 changed by arnonym

  • status changed from new to closed.
  • resolution set to fixed.

Fixed in r1897.