Ticket #123 (closed enhancement: fixed)

Opened 13 years ago

Last modified 13 years ago

ffadomixer: Terratec PHASE X24 and Terratec PHASE 24 need different mixer GUIs

Reported by: slack Assigned to: ppalmers
Priority: minor Milestone: FFADO 2.0
Component: Version: FFADO 2.0-beta5.1 (1.999.32)
Keywords: Cc:
The device the bug applies to:

Description

The PHASE X24 has a digital volume control / muting switch for the channels 1/2 and 3/4 on the front pannel.

As a consequence, it seems that these settings are not changeable anymore.

Here is the commented output of ffado-dbus-server (NON-DEBUG):

Starting ffado-dbus-server in a console window...

$ ffado-dbus-server FFADO Control DBUS service

Discovering devices... Starting DBUS service... Running... (press ctrl-c to stop & exit)

Starting ffadomixer gives the following output...

14102427193: Warning (bebob_avdevice.cpp)[ 323] getFeatureFBVolumeValue: fbCmd.getResponse() != AVCCommand::eR_Implemented

I made some tests, and found that the above message is caused by the following statement:

val=self.hw.getContignuous('/Mixer/Feature_8')

Changing the "Master" volume in the "Hardware Mixer"...

14181597195: Warning (bebob_avdevice.cpp)[ 292] setFeatureFBVolumeValue: fbCmd.getResponse() != AVCCommand::eR_Accepted

The corresponding message from ffadomixer: setting master volume to -1000

Changing the "3/4 Out Level"...

14349394421: Warning (bebob_avdevice.cpp)[ 292] setFeatureFBVolumeValue: fbCmd.getResponse() != AVCCommand::eR_Accepted

The corresponding message from ffadomixer: setting front level to 1536

All other controls are working on the PHASE X24 as expected and there are no warnings from ffado-dbus-server.

Change History

05/29/08 13:07:42 changed by ppalmers

  • status changed from new to assigned.
  • owner set to ppalmers.

r1236 implements a fix for this. please test.

05/30/08 09:08:49 changed by slack

Changeset 1237 works great with my Terratec Phase X24.

Thanks

P.S.: Nice idea to just disable the two controls.

05/31/08 05:12:04 changed by ppalmers

  • status changed from assigned to closed.
  • resolution set to fixed.

No need to introduce more maintenance work than needed.