Ticket #127 (closed bug: fixed)

Opened 13 years ago

Last modified 13 years ago

ffado cannot create receive processor white Saffire

Reported by: kooox Assigned to: ppalmers
Priority: blocker Milestone: FFADO 2.0
Component: Version:
Keywords: Cc: dietrich, earthwormgaz
The device the bug applies to:

Description

Using r1239 with a white Saffire, ffado fails to find receive plug channels:

1609013079: Error (avc_avdevice.cpp)[ 452] prepare: Receive plug has no channels
01609013090: Debug (StreamProcessorManager.cpp)[ 246] setSyncSource: Setting sync source to ((nil))
01609013105: Debug (ffado.cpp)[ 182] ffado_streaming_prepare: Preparing...
01609013111: Debug (StreamProcessorManager.cpp)[ 253] prepare: Preparing...
01609013117: Warning (StreamProcessorManager.cpp)[ 263] prepare: Sync Source is not set. Defaulting to first StreamProcessor.
01609013123: Debug (StreamProcessorManager.cpp)[ 287] prepare: Prepare Receive processors...
01609013128: Debug (StreamProcessorManager.cpp)[ 301] prepare: Prepare Transmit processors...
01609013132: Fatal (StreamProcessorManager.cpp)[ 317] prepare: No stream processors registered, can't do anything usefull
01609013137: Fatal (devicemanager.cpp)[ 692] prepareStreaming: Could not prepare streaming...
01609013142: Fatal (ffado.cpp)[ 185] ffado_streaming_prepare: Could not prepare the streaming system

jackd started with -R -P70 -u -dfirewire -r48000 -p256 -n4 -i4 -o8 -v6.

I removed the cache in ~/.ffado but this changes nothing. See full jackd and test-ffado Discover outputs attached.

Attachments

jackd.log (92.0 kB) - added by kooox on 06/01/08 05:21:59.
jackd output
test-ffado (271.6 kB) - added by kooox on 06/01/08 05:22:45.
test-ffado Discover output

Change History

06/01/08 05:21:59 changed by kooox

  • attachment jackd.log added.

jackd output

06/01/08 05:22:45 changed by kooox

  • attachment test-ffado added.

test-ffado Discover output

06/01/08 09:34:43 changed by ppalmers

  • status changed from new to assigned.
  • owner set to ppalmers.
  • version deleted.

this was introduced by [1238]. Will look at it later, no time now.

06/01/08 13:16:43 changed by slack

Hi, kooox, pieter!

Had(!) the same problem, you could try my patch (See ticket #129).

06/02/08 00:24:52 changed by ppalmers

  • status changed from assigned to closed.
  • resolution set to fixed.

(In [1241]) update BeBoB constructors (thx slack) (closes #129, #127)

06/04/08 10:16:50 changed by kooox

  • status changed from closed to reopened.
  • resolution deleted.

I still get the same errors with r1241 and r1242. Reverting to last working revision (r1237).

06/04/08 12:05:29 changed by slack

Hi, kooox!

In my case it was very helpful to compare the jackd debug log of the last working revision with the first not working one after trimming both a little bit.

Please try to change as little as possible between the two runs and remove the cache each time.

This will simplify things afterwards when looking through the logs.

Thanks

06/04/08 13:14:40 changed by kooox

Thanks for the advice. I'll look into it as soon as I have some time (probably tomorrow).

06/05/08 01:05:17 changed by ppalmers

  • cc set to dietrich.

06/05/08 01:23:18 changed by ppalmers

  • priority changed from major to blocker.

06/05/08 11:13:49 changed by earthwormgaz

  • cc changed from dietrich to dietrich, earthwormgaz.

06/05/08 11:35:32 changed by dietrich

Hello Pieter, Hello Slack,

I just applied the patch from #129 "bebob_add_constructors.diff" and now it works!!!

FFADO already works very, very well for my needs. OK, I only use it for 8 channel playback. I can test new svn-versions with my equipment, if this helps You. Just let me know ( dietrich at imgn.de ).

Thank You very much!

06/05/08 11:50:29 changed by ppalmers

  • status changed from reopened to closed.
  • resolution set to fixed.

kooox, please specify if you were using the trunk or the 2.0 branch. The bug was fixed in the 2.0 branch, but the fix was only merged to the trunk in r1245.

For me it works, and I think it's fixed. Hence I close the ticket.

06/05/08 12:09:19 changed by earthwormgaz

Yup, updated from SVN, it works now. 1st time too, so better than freebob! woohoo!

06/05/08 12:09:43 changed by earthwormgaz

That's on trunk btw ...

06/05/08 12:18:20 changed by kooox

Pieter,

I've always been using trunk, I didn't know the fix was only applied to the 2.0 branch... I don't have enough time to test r1245+ right now, but I trust you on that :)

Thanks for the good work. Will try up to date trunk ASAP.

Greets