Ticket #144 (closed enhancement: duplicate)

Opened 6 years ago

Last modified 3 years ago

saffire pro 26 jackd crash w/ "disable adat i/o" mixer flag

Reported by: nettings Assigned to:
Priority: major Milestone: FFADO 2.x
Component: Version: FFADO SVN (trunk)
Keywords: Cc:
The device the bug applies to: saffire pro 26

Description

on a saffire pro 26 w/ latest jackd svn, i can reliably crash jackd by checking "disable adat i/o" in ffadomixer while the device is running, and then unchecking it again.

JACK error: cannot read server event (Success) JACK error: cannot continue execution of the processing graph (Broken pipe) JACK error: zombified - calling shutdown handler [1]+ Killed qjackctl

not a showstopper for me at this point, but kinda weird.

Change History

07/11/08 01:34:12 changed by ppalmers

  • type changed from bug to enhancement.

This is not really a bug, since it's expected behavior.

The problem is that disabling the ADAT channels will cause the device to bus-reset and change its stream composition. The FFADO streaming system can't handle that at the moment.

03/28/12 05:25:43 changed by jwoithe

  • status changed from new to closed.
  • resolution set to duplicate.

The issues in this ticket are very closely related to those in ticket #168. Let's continue the discussion there.

03/28/12 05:26:05 changed by jwoithe

  • milestone changed from FFADO 2.1 to FFADO 2.x.