Ticket #15 (closed bug: fixed)

Opened 13 years ago

Last modified 12 years ago

test-ffado Discover crashes (FA101)

Reported by: carlotheman Assigned to: wagi
Priority: major Milestone: FFADO 2.x
Component: Version:
Keywords: Cc:
The device the bug applies to: FA-101

Description

On installing FFADO on Ubuntu Feisty Fawn, running test-ffado Discover crashes with the following message:

-- Warning (bebob_avdevice_subunit.cpp)[ 473] createFunctionBlock: Dummy function block processing created. Implementation is missing Segmentation fault (core dumped) --

libraw1394 and libffado SVN versions as of 8 May 07

Device: Edirol FA-101. Freebob 1.0 works.

Carlo

Attachments

stacktrace.txt (2.3 kB) - added by carlotheman on 05/14/07 05:44:38.
Stack Trace for test-ffado Discover crash

Change History

05/10/07 04:04:19 changed by ppalmers

  • owner set to ppalmers.
  • status changed from new to assigned.

Can you provide a stack trace?

(follow-up: ↓ 3 ) 05/14/07 05:42:14 changed by carlotheman

OK got the trace... did:

$ libtool --mode=execute gdb test-ffado

(gdb) run Discover

Starting program: /home/carlo/software/libffado/tests/.libs/lt-test-ffado Discover [Thread debugging using libthread_db enabled] [New Thread -1215150384 (LWP 5770)] [New Thread -1217254512 (LWP 5773)] verbose level = 0 Using ffado library version: libffado 1.999.4

[New Thread -1225647216 (LWP 5774)] [New Thread -1234220144 (LWP 5775)] Warning (bebob_avdevice_subunit.cpp)[ 473] createFunctionBlock: Dummy function block processing created. Implementation is missing Error (bebob_avplug.cpp)[ 285] discoverPlugType: plug type command failed Error (bebob_avplug.cpp)[ 135] discover: discover: Could not discover plug type (0,1,0,0,0) Error (bebob_functionblock.cpp)[ 124] discoverPlugs: plug discovering failed for plug 0 Error (bebob_functionblock.cpp)[ 91] discover: Could not discover input plug for 'Dummy Processing' Error (bebob_avdevice_subunit.cpp)[ 500] createFunctionBlock: Could not discover function block Dummy Processing Error (bebob_avdevice_subunit.cpp)[ 336] discoverFunctionBlocks: Could not discover function block processing Error (bebob_avdevice_subunit.cpp)[ 279] discover: function block discovering failed Error (bebob_avdevice.cpp)[ 620] enumerateSubUnits: enumerateSubUnits: Could not discover subunit_id = 0, subunit_type = 1 (Audio) Error (bebob_avdevice.cpp)[ 170] discover: Could not enumarate sub units Error (devicemanager.cpp)[ 236] discover: discover: could not discover device

Program received signal SIGSEGV, Segmentation fault. [Switching to Thread -1215150384 (LWP 5770)] 0x00000031 in ?? ()

(gdb) backtrace

#0 0x00000031 in ?? () #1 0xb7ec111e in ~AvDevice? (this=0x80568e0) at bebob/bebob_avdevice.cpp:95 #2 0xb7e80353 in DeviceManager::discover (this=0x804ff98)

at devicemanager.cpp:251

#3 0x0804baa2 in main (argc=134574072, argv=0x8056ffc) at test-ffado.cpp:234

(gdb) exit

Hope this helps.

Carlo

(in reply to: ↑ 2 ) 05/14/07 05:43:03 changed by carlotheman

Added same thing as text file...

05/14/07 05:44:38 changed by carlotheman

  • attachment stacktrace.txt added.

Stack Trace for test-ffado Discover crash

10/21/07 05:40:56 changed by ppalmers

  • owner changed from ppalmers to wagi.
  • priority changed from blocker to major.
  • milestone changed from FFADO 2.0 to FFADO 2.x.
  • status changed from assigned to new.
  • device_name changed.

The edirol FA-101 is not an officially supported device, hence this is not a priority bug for the release of FFADO 2.0.

10/21/07 05:41:12 changed by ppalmers

  • device_name set to FA-101.

10/21/07 05:49:28 changed by ppalmers

  • summary changed from test-ffado Discover crashes to test-ffado Discover crashes (FA101).

11/25/07 13:13:48 changed by wagi

  • status changed from new to assigned.

ok, the fa-101 has a simple mixer inside. the discovering code wants to create some dummy representation for the mixer. maybe we should just disable that part, because the mixer is anyway rather limited. is that acceptable for an workaround?

12/18/07 04:47:07 changed by wagi

I tried to reproduces the bug, but as it seems the current head doesn't have this problem anymore. It is possible to have an dummy feature function block.

Could you try to trigger the bug with the trunk again? Thanks

01/06/08 08:59:15 changed by wagi

we got following on the mailing list today:

Hi guys,

I'm trying to playing around with FFADO by curiosity (freebob works almost perfectly), but I can't get it working.

I have an Ubuntu real-time platform, updated with every thing necessary to build the latest libffado.

The build (svn 823) is done fine, apart a few warnings and this message at the end : "... scons: done building targets. Exception exceptions.TypeError?: TypeError?("'NoneType?' object is not callable",) in <bound method Popen3.del of <popen2.Popen3 instance at 0xb7818ecc>> ignored "

when I try to run test-ffado with a FA-101 connected, here is the output:

matt@matt-laptop:/usr/src/libffado-823/tests$ ./test-ffado Discover verbose level = 0 Using ffado library version: libffado 1.999.11-823

3654455753: Debug (ieee1394service.cpp)[ 201] initialize: This system supports the raw1394_read_cycle_timer call, using it. 3654464577: Debug (devicemanager.cpp)[ 296] discover: driver found for device 1 3654492243: Debug (bebob_avdevice.cpp)[ 429] loadFromCache: filename /home/matt/.ffado/cache/0040ab0000c21f44/60070404.xml 3654492315: Debug (bebob_avdevice.cpp)[ 433] loadFromCache: "/home/matt/.ffado/cache/0040ab0000c21f44/60070404.xml" does not exist 3654496550: Debug (bebob_avdevice_subunit.cpp)[ 83] discover: Discovering BeBoB::AudioSubunit?... 3654496577: Debug (avc_audiosubunit.cpp)[ 55] discover: Discovering BeBoB::AudioSubunit?... 3654496588: Debug (avc_subunit.cpp)[ 108] discoverPlugs: Discovering plugs... 3654893097: Debug (bebob_avdevice_subunit.cpp)[ 132] discoverFunctionBlocks: Discovering function blocks... 3654908302: Warning (bebob_avdevice_subunit.cpp)[ 286] createFunctionBlock: Dummy function block processing created. Implementation is missing 3654908341: Debug (bebob_functionblock.cpp)[ 91] discover: discover function block Dummy Processing (nr of input plugs = 1, nr of output plugs = 1) 3654911591: Error (bebob_avplug.cpp)[ 160] discoverPlugType: plug type command failed 3654911609: Error (bebob_avplug.cpp)[ 88] discover: discover: Could not discover plug type (1,1,0,0,0) 3654911620: Error (bebob_functionblock.cpp)[ 124] discoverPlugs: plug discovering failed for plug 0 3654911668: Error (bebob_functionblock.cpp)[ 95] discover: Could not discover input plug for 'Dummy Processing' 3654911686: Error (bebob_avdevice_subunit.cpp)[ 313] createFunctionBlock: Could not discover function block Dummy Processing 3654911711: Error (bebob_avdevice_subunit.cpp)[ 149] discoverFunctionBlocks: Could not discover function block processing 3654911737: Error (bebob_avdevice_subunit.cpp)[ 92] discover: function block discovering failed 3654911745: Error (avc_unit.cpp)[ 264] enumerateSubUnits: enumerateSubUnits: Could not discover subunit_id = 0, subunit_type = 1 (Audio) 3654911829: Error (avc_unit.cpp)[ 178] discover: Could not enumarate sub units 3654911843: Error (bebob_avdevice.cpp)[ 134] discover: Could not discover unit 3654911874: Error (devicemanager.cpp)[ 308] discover: could not discover device 3654911994: Debug (devicemanager.cpp)[ 338] discover: Discovery finished... 3654912011: Debug (devicemanager.cpp)[ 785] showDeviceInfo: ===== Device Manager ===== 3654912022: Debug (Element.cpp)[ 59] show: Element DeviceManager? 3654912045: Debug (devicemanager.cpp)[ 793] showDeviceInfo: --- IEEE1394 Service 0 --- Iso handler info: Dumping IsoHandlerManager? Stream handler information...

State: 2

no message buffer overruns matt@matt-laptop:/usr/src/libffado-823/tests$

And if I try to lunch jackd (0.108.1), it segfaults.

Is there something wrong (me, or some bugs) or it still normal at this stage?

Cheers, Matt

01/06/08 09:00:13 changed by wagi

argh, better formatting needed:

Hi guys,

I'm trying to playing around with FFADO by curiosity (freebob works
almost perfectly), but I can't get it working.

I have an Ubuntu real-time platform, updated with every thing
necessary to build the latest libffado.

The build (svn 823) is done fine, apart a few warnings and this
message at the end :
"...
scons: done building targets.
Exception exceptions.TypeError: TypeError("'NoneType' object is not
callable",) in <bound method Popen3.__del__ of <popen2.Popen3 instance
at 0xb7818ecc>> ignored
"

when I try to run test-ffado with a FA-101 connected, here is the output:

matt@matt-laptop:/usr/src/libffado-823/tests$ ./test-ffado Discover
verbose level = 0
Using ffado library version: libffado 1.999.11-823

3654455753: Debug (ieee1394service.cpp)[ 201] initialize: This system
supports the raw1394_read_cycle_timer call, using it.
3654464577: Debug (devicemanager.cpp)[ 296] discover: driver found for device 1
3654492243: Debug (bebob_avdevice.cpp)[ 429] loadFromCache: filename
/home/matt/.ffado/cache/0040ab0000c21f44/60070404.xml
3654492315: Debug (bebob_avdevice.cpp)[ 433] loadFromCache:
"/home/matt/.ffado/cache/0040ab0000c21f44/60070404.xml" does not exist
3654496550: Debug (bebob_avdevice_subunit.cpp)[  83] discover:
Discovering BeBoB::AudioSubunit...
3654496577: Debug (avc_audiosubunit.cpp)[  55] discover: Discovering
BeBoB::AudioSubunit...
3654496588: Debug (avc_subunit.cpp)[ 108] discoverPlugs: Discovering plugs...
3654893097: Debug (bebob_avdevice_subunit.cpp)[ 132]
discoverFunctionBlocks: Discovering function blocks...
3654908302: Warning (bebob_avdevice_subunit.cpp)[ 286]
createFunctionBlock: Dummy function block processing created.
Implementation is missing
3654908341: Debug (bebob_functionblock.cpp)[  91] discover: discover
function block Dummy Processing (nr of input plugs = 1, nr of output
plugs = 1)
3654911591: Error (bebob_avplug.cpp)[ 160] discoverPlugType: plug type
command failed
3654911609: Error (bebob_avplug.cpp)[  88] discover: discover: Could
not discover plug type (1,1,0,0,0)
3654911620: Error (bebob_functionblock.cpp)[ 124] discoverPlugs: plug
discovering failed for plug 0
3654911668: Error (bebob_functionblock.cpp)[  95] discover: Could not
discover input plug for 'Dummy Processing'
3654911686: Error (bebob_avdevice_subunit.cpp)[ 313]
createFunctionBlock: Could not discover function block Dummy
Processing
3654911711: Error (bebob_avdevice_subunit.cpp)[ 149]
discoverFunctionBlocks: Could not discover function block processing
3654911737: Error (bebob_avdevice_subunit.cpp)[  92] discover:
function block discovering failed
3654911745: Error (avc_unit.cpp)[ 264] enumerateSubUnits:
enumerateSubUnits: Could not discover subunit_id =  0, subunit_type =
1 (Audio)
3654911829: Error (avc_unit.cpp)[ 178] discover: Could not enumarate sub units
3654911843: Error (bebob_avdevice.cpp)[ 134] discover: Could not discover unit
3654911874: Error (devicemanager.cpp)[ 308] discover: could not discover device
3654911994: Debug (devicemanager.cpp)[ 338] discover: Discovery finished...
3654912011: Debug (devicemanager.cpp)[ 785] showDeviceInfo: =====
Device Manager =====
3654912022: Debug (Element.cpp)[  59] show: Element DeviceManager
3654912045: Debug (devicemanager.cpp)[ 793] showDeviceInfo: ---
IEEE1394 Service  0 ---
Iso handler info:
Dumping IsoHandlerManager Stream handler information...
 State: 2
no message buffer overruns
matt@matt-laptop:/usr/src/libffado-823/tests$

And if I try to lunch jackd (0.108.1), it segfaults.

Is there something wrong (me, or some bugs) or it still normal at this stage?

Cheers,
Matt

01/20/08 03:49:03 changed by wagi

  • status changed from assigned to closed.
  • resolution set to fixed.

fixed in r865

01/21/08 11:24:30 changed by wagi

  • status changed from closed to reopened.
  • resolution deleted.

Still not fixed.

As it seems it is not possible to discover the music subunit plugs.

01/21/08 11:30:56 changed by wagi

let's try to discover this device using the descriptor approach (see #872)

02/17/08 03:44:04 changed by carlotheman

Re-tested revision 876 and device discovery seems to work properly now. Thank you!

05/03/08 13:09:54 changed by wagi

I have again my fa-101 back. I have enabled again the bebob specific discovering code (r1109) and I could recreated the problem. carlotheman can you test the new version again? Thanks.

05/20/08 10:31:52 changed by wagi

Ticket #108 seems to be identical to this problem. r1183 or later should fix this. Can you confirm?

06/15/08 08:51:31 changed by wagi

  • status changed from reopened to closed.
  • resolution set to fixed.

I close this bug now. The other related bugs to this one are now all fixed. So I belive this problem should also be fixed now. Otherwise please reopen this ticket.