Ticket #190 (closed bug: wontfix)

Opened 6 years ago

Last modified 6 years ago

CycleTimerHelper.cpp Execute: Early wakeup, should not happen!

Reported by: elias Assigned to:
Priority: minor Milestone: FFADO 2.0
Component: Version: FFADO 2.0-rc1 (1.999.40)
Keywords: Cc:
The device the bug applies to:

Description

After installing a recompiled RT Kernel I get the following error (it is a non-stopping list with different ID numbers at the start of the line)

01353417769: Error (CycleTimerHelper?.cpp)[ 463] Execute: Early wakeup, should not happen!

This is the second time this error appears: First after my first build of the kernel. I rebuilt, this time with al power management options turned off.

After the new built everything worked fine. Only: after reboot the second day this error became persistent.

I do not think it is the kernel at this stage, but cannot figure out what is.

The kernel I'm using is 2.6.26.9-rt12. The base distribution is 64Studio

Running ffado-diag gave an error (which I think is due to lack of debugging output from the kernel)

frans@64studio:/usr/local/bin$ sudo ffado-diag > ~/Desktop/ffado.log Traceback (most recent call last):

File "/usr/local/bin/ffado-diag", line 30, in <module>

from listirqinfo import IRQ,SoftIRQ,IRQInfo

ImportError?: No module named listirqinfo frans@64studio:/usr/local/bin$

Thanks for all your work.

Change History

(follow-up: ↓ 2 ) 12/28/08 07:30:23 changed by ppalmers

The ffado-diag error is due to the fact that some files are not installed correctly by the installer. This will be fixed in the next release candidate. In the meantime, you can run the ffado-diag tool from the support/tools directory of the ffado source tree.

Regarding the core issue you have:

In src/libieee1394/CycleTimerHelper.cpp line 457 it should say

if (ticks_late > 0) {

can you see if changing it to:

if (ticks_late >= 0) {

helps?

(recompile and reinstall libffado)

(in reply to: ↑ 1 ) 01/02/09 02:20:45 changed by elias

  • priority changed from critical to minor.
  • status changed from new to closed.
  • resolution set to wontfix.

Thanks for the fast response.

The weirdest thing is that the error I reported has not returned for a while. Sometimes it seems to be caused by by having multiple instances of ffado-dbus-server running. Killing these processes in the Systemmonitor and then starting them again solves it.

What I do not understand is that I cannot replicate the error in any way. Not even by starting up the process as root and as user.

I'm sorry to say that I cannot check your proposed solution. As soon as I start to recompile I get error messages again from scons about QT and about a popen3.popen2 instance. I solved all these issues in a long night earlier and managed to compile, so I cannot afford to get into that again.

The configuration I have now seems to work, so I'm not touching it until I absolutely need to.

That being said: this means that I have a my little portable studio going thank to you!