Ticket #194 (closed feature: invalid)

Opened 6 years ago

Last modified 5 years ago

MIDI: Device present in "MIDI", not in "Alsa" (qjackctl)

Reported by: blindekinder Assigned to:
Priority: minor Milestone: FFADO 2.x
Component: Version: FFADO 2.0-rc1 (1.999.40)
Keywords: Cc:
The device the bug applies to:

Description

Hi, I use an Edirol FA-101 with ffado 2.0, jack 0.116.1 and qjackctl 0.3.4. Sound works, but midi physical port doesn't appear in "Alsa", only in "Midi". In "Patchage", I see the port (firewire_pcm midi-port), but it doesn't let me connect it to anything.

Change History

01/20/09 03:53:09 changed by adi

  • priority changed from major to minor.
  • type changed from bug to feature.
  • milestone changed from FFADO 2.0 to FFADO 2.x.

Hi.

That's completely normal. There are multiple different frameworks to access a MIDI port. Your application only supports the alsa-seq interface, not the jack-midi (jack-midi is what you see in qjackctl's "MIDI" page).

Three ways to fix:

  • convince your application developer to support jack midi (probably a good idea)
  • convince FFADO to export the MIDI port to alsa-seq (don't know what FFADO's alsa plugin does)
  • use a software bridge to export your jack midi ports to alsa-seq. (http://home.gna.org/a2jmidid/)

The last option is your instant fix, giving you the ports immediately.

HTH

PS: Linuxsampler is an example for an application supporting the jack-midi API.

09/22/09 15:02:47 changed by arnonym

  • status changed from new to closed.
  • resolution set to invalid.

This is a bug, its a feature. Jack-MIDI is believed to be better then alsa-midi.

So only the first and third options really remain. ("a2jmidi -e" rulez!)

09/22/09 15:07:41 changed by arnonym

Last one should have been "Its not a bug, ...".