Ticket #205 (closed bug: fixed)

Opened 6 years ago

Last modified 6 years ago

Fail after successful connect to card

Reported by: muranyia Assigned to: jwoithe
Priority: major Milestone: FFADO 2.0
Component: Version: FFADO 2.0-rc1 (1.999.40)
Keywords: Cc:
The device the bug applies to: MOTU 828mkII

Description

~$ /usr/bin/jackd -v -R -P85 -t1000 -dfirewire -r48000 -p128 -n3

getting driver descriptor from /usr/lib/jack/jack_alsa.so getting driver descriptor from /usr/lib/jack/jack_oss.so getting driver descriptor from /usr/lib/jack/jack_freebob.so getting driver descriptor from /usr/lib/jack/jack_firewire.so no message buffer overruns getting driver descriptor from /usr/lib/jack/jack_dummy.so getting driver descriptor from /usr/lib/jack/jack_net.so jackd 0.116.1 Copyright 2001-2005 Paul Davis and others. jackd comes with ABSOLUTELY NO WARRANTY This is free software, and you are welcome to redistribute it under certain conditions; see the file COPYING for details

JACK compiled with System V SHM support. server `default' registered registered builtin port type 32 bit float mono audio registered builtin port type 8 bit raw midi clock source = system clock via clock_gettime start poll on 3 fd's loading driver .. new client: firewire_pcm, id = 1 type 1 @ 0x72cd00 fd = -1 Enhanced3DNow! detected SSE2 detected new buffer size 128 05878729515: (ffado.cpp)[ 92] ffado_streaming_init: libffado 1.999.40- built Jan 22 2009 12:33:23 firewire MSG: Streaming thread running with Realtime scheduling, priority 85 firewire MSG: Registering audio capture port C0_dev0_cap_Mix-L registered port system:capture_1, offset = 512 ... etc registering all ports... ... registered port system:playback_22, offset = 0 firewire MSG: Don't register playback port dev0_pbk_ADAT8 ++ jack_sort_graph ++ jack_rechain_graph(): +++ client is now firewire_pcm active ? 1 client firewire_pcm: internal client, execution_order=0. -- jack_rechain_graph() -- jack_sort_graph 6907 waiting for signals jackd: src/ffado.cpp:427: int ffado_streaming_set_playback_stream_buffer(ffado_device_t*, int, char*): Assertion `p' failed. Aborted

Change History

03/24/09 15:46:32 changed by jwoithe

  • owner set to jwoithe.

Could you please try the latest 2.0 svn branch? The 2.0-rc1 release was broken for MOTU due to a last minute infrastructure change which apparently wasn't expected to cause regressions but did anyway. I suspect the problem you're seeing is related to this.

If you need further info about checking out an svn snapshot please email me directly.

03/25/09 12:01:09 changed by muranyia

  • status changed from new to closed.
  • resolution set to fixed.

Jonathan, Thanks a lot, 2.999.0-1524 works alrite with my MOTU.