Ticket #208 (closed bug: fixed)

Opened 5 years ago

Last modified 5 years ago

Saffire LE started and stopped by Jack after just a couple of seconds

Reported by: furenku Assigned to:
Priority: critical Milestone: FFADO 2.0
Component: Version: FFADO SVN (trunk)
Keywords: saffire, hardy, texas instruments chipset, broken pipe Cc:
The device the bug applies to:

Description

I've installed FFADO and Jack through SVN. Everytime I start Jack, the sound card gets activated (LEDs turn on, a relay sounds), but jack only stays connected for a couple of seconds. Then it just stops (sometimes crashes) with the following error:

firewire ERR: Could not start streaming threads: -1

then the following message starts flooding the screen:

cannot continue execution of the processing graph (Broken pipe)

I'm trying to use a Focusrite Saffire LE running FFADO on Ubuntu Hardy 8.04, fresh install. I'm using a Belkin Firewire 400 Expresscard with a TI chipset.

I've already tried using the FFADO packages, the tarball with the sources, and SVN.

Any pointers would be greatly appreciated.

Sincerely, Rodrigo Frenk

Attachments

ffado-logs.tar.gz (16.6 kB) - added by furenku on 03/26/09 18:51:35.
ffado logs
ffado-jack.log-2nd_try.tar.gz (47.1 kB) - added by furenku on 03/27/09 06:25:23.
Jack performance log after the suggested modifications
ffado-jack-3rdTry.log (1.1 MB) - added by furenku on 03/28/09 04:35:11.
corrected ffado-jack.log

Change History

03/26/09 18:51:35 changed by furenku

  • attachment ffado-logs.tar.gz added.

ffado logs

(follow-up: ↓ 2 ) 03/27/09 01:08:32 changed by ppalmers

Some extra questions/remarks:

  • Can you run jack with realtime priority
  • Make sure the saffire is freshly power cycled
  • try the 2.0 SVN branch instead of SVN trunk

03/27/09 06:25:23 changed by furenku

  • attachment ffado-jack.log-2nd_try.tar.gz added.

Jack performance log after the suggested modifications

(in reply to: ↑ 1 ; follow-up: ↓ 3 ) 03/27/09 06:25:49 changed by furenku

I installed the 2.0 SVN Branch, obtained from the following address:

http://subversion.ffado.org/ffado/branches/libffado-2.0/

I recompiled jack.

After clicking 'Force Bus Reset' on gscanbus, I ran jack with the following options:

jackd --verbose -R -P 70 -d firewire -v6 2> ffado-jack.log

I still didn't have success, jack's output in the console was:

starting server engine shutdown stopping driver server thread back from poll unloading driver freeing shared port segments stopping server thread stopping watchdog thread last xrun delay: 0.000 usecs

The new log is attached and named "2nd_try"

thanks again,

Rodrigo

(in reply to: ↑ 2 ) 03/28/09 04:34:18 changed by furenku

Something went wrong with my las ffado-jack.log file; it showed only a couple of lines. I performed a test again using the following command:

jackd --verbose -R -P70 -d firewire -v6 2> ffado-jack.log

The corrected ffado-jack.log is attached with the name ffado-jack-3rdTry-log

03/28/09 04:35:11 changed by furenku

  • attachment ffado-jack-3rdTry.log added.

corrected ffado-jack.log

03/28/09 08:25:02 changed by ppalmers

You're experiencing a problem in the kernel modules that causes the transmit handler to stall. This should be solved for kernels since 2.6.26.

If you're comfortable with recompiling a kernel module, take a look at the following page: TxSkipPatched. It contains a fixed version of the 2.6.24 drivers. The OutOfTreeModules page might also help.

05/17/09 03:50:49 changed by ppalmers

  • status changed from new to closed.
  • resolution set to fixed.