Ticket #213 (closed bug: duplicate)

Opened 11 years ago

Last modified 8 years ago

After some minutes of working ffado-dbus-server starts writing errors every half second.

Reported by: whitewind Assigned to:
Priority: major Milestone: FFADO 2.1
Component: Version: FFADO 2.0-rc1 (1.999.40)
Keywords: negative step, audiofire2, CycleTimerHelper.cpp Cc:
The device the bug applies to: AUDIOFIRE2

Description

I am using OpenSuse? OS and AUDIOFIRE2. After I start ffado-dbus-server, it works only a few minutes (sometimes seconds) and starts writing errors in the current terminal window with message like: "[0m04315114981: [31mError (CycleTimerHelper.cpp)[ 517] Execute: negative step: -7803953481.859039! (correcting to nominal)" . There is no difference, am i running jackd or not. But after it falls to errors jackd is stopped and won`t start again. I am able to get sound working before the "error storm". When I restart both servers, I get the all the same problems again.

Attachments

report.tgz (0.6 MB) - added by whitewind on 04/12/09 12:18:30.

Change History

04/12/09 12:18:30 changed by whitewind

  • attachment report.tgz added.

04/12/09 13:38:17 changed by ppalmers

A first note is that you should run jack with the -R flag to enable realtime scheduling. Otherwise FFADO won't work reliably.

I'll check the negative step warning.

11/22/09 10:19:17 changed by ppalmers

  • milestone changed from FFADO 2.0 to FFADO 2.1.

moving this to 2.1

03/29/12 06:59:29 changed by jwoithe

This sounds similar to the "negative step" warnings reported in ticket #270. However, while that ticket reports the warnings coming from jackd, this current ticket says that they come from ffado-dbus-server, which is odd because ffado-dbus-server doesn't activate streaming and therefore I wouldn't have thought it had any need for the cycle timer.

So, is this a duplicate of ticket #270?

04/07/12 04:56:18 changed by jwoithe

  • status changed from new to closed.
  • resolution set to duplicate.

In the absence of further feedback I'll close this ticket as a duplicate of ticket #270. The descriptions in both are similar enough to believe that they have the same underlying cause. Further discussion can take place in ticket #270, and if it turns out that this ticket really is different it can always be reopened.

The only niggle I have is that the report here mentioned that the timing errors come from ffado-dbus-server, and yet I didn't think ffado-dbus-server interacted with the cycle timer because it doesn't start the streaming subsystem. In any case, without further information from people suffering the problem we can't take this further.