Ticket #217 (closed bug: worksforme)

Opened 5 years ago

Last modified 2 years ago

jackd dies predictably after 5secs on TI ExpressCard / Saffire

Reported by: peppo Assigned to:
Priority: major Milestone: FFADO 2.x
Component: Version: FFADO 2.0-rc1 (1.999.40)
Keywords: Cc:
The device the bug applies to:

Description

jackd dies a predictable death after circa 5secs running on a TI ExpressCard?

Attaching ffado-diag and log

Attachments

ffado-diag.txt (5.7 kB) - added by peppo on 05/05/09 12:59:25.
ffado-jack.log.gz (286.2 kB) - added by peppo on 05/05/09 12:59:49.

Change History

05/05/09 12:59:25 changed by peppo

  • attachment ffado-diag.txt added.

05/05/09 12:59:49 changed by peppo

  • attachment ffado-jack.log.gz added.

05/05/09 13:30:30 changed by peppo

Same error when running with current (090505 21:30 gmt+1) svn!

05/17/09 04:26:08 changed by ppalmers

this is a very weird error. Does it also happen if you boot with the expresscard inserted?

05/17/09 13:21:01 changed by peppo

It does not. Starting the computer with the card inserted results in pretty good performance. It did die in one session, and I had to powercycle the Saffire... I'll see if I can get some debug data on that.

09/22/09 14:48:18 changed by arnonym

Hi,

I noticed that you aren't using a rt-patched kernel. At least ffado-diag tells me that.

Did you ever try a rt-kernel?

10/08/09 09:17:18 changed by stefanr

Why does the subject say "TI ExpressCard?" but the diagnostic log "Ricoh Co Ltd R5C832 IEEE 1394 Controller"?

(follow-up: ↓ 7 ) 10/12/09 14:22:03 changed by arnonym

@stefanr: Could be ffado-diag has a problem finding all firewire adaptors. I can't test as I have only one...

(in reply to: ↑ 6 ) 10/12/09 17:20:51 changed by stefanr

@arnonym: OK, could be. Though recent ffado-diag (checked: revisions 1569 and 1687) does nicely list all three controllers in this box here.

11/21/09 12:10:35 changed by ppalmers

  • milestone changed from FFADO 2.0 to FFADO 2.1.

This is one of the bugs that is too difficult to track and solve to be blocking for 2.0. Tough luck for those affected. Once we're moving to kernel streaming it might be easier to track and find these issues as it should be simpler.

03/28/12 04:53:02 changed by jwoithe

  • milestone changed from FFADO 2.1 to FFADO 2.x.

There's been no further developments in this ticket for over 2 years so it's clear that this won't be resolved prior to 2.1, so I'll defer it. Without further information from those affected it's going to be very difficult to track this one down. I'll be tempted to close this as "worksforme" unless someone manages to reproduce the fault with a current ffado.

03/28/12 06:28:40 changed by peppo

I no longer have a FW device, so as far as I am concerned, I can't help with any more info...

03/28/12 15:35:41 changed by jwoithe

  • status changed from new to closed.
  • resolution set to worksforme.

Since the original reporter no longer has the hardware to continue diagnostic work and there are apparently no others seeing this particular set of symptoms I'll close this as "worksforme". If the problem surfaces again please re-open this ticket and we'll resume the detective work.