Ticket #230 (closed bug: worksforme)

Opened 5 years ago

Last modified 5 years ago

firewire ERR (audiofire 8 - ubuntu 9.04)

Reported by: kro Assigned to:
Priority: major Milestone: FFADO 2.0
Component: Version: FFADO 2.0-rc1 (1.999.40)
Keywords: firewire audiofire Cc:
The device the bug applies to:

Description

hi

im trying to make use of my audiofire 8 on ubuntu 9.04 (jaunty)

it seems ok with ffado-test listdevices :

=== 1394 PORT 0 ===
  Node id  GUID                  VendorId     ModelId   Vendor - Model
   0       0x00148606bd2ea2be  0x00001486  0x00000AF8   Echo Digital Audio - AudioFire8
   1       0x00080da0d15d9f45  0x0000080D  0x00000000   Linux - ohci1394  - 
no message buffer overruns

but jackd fails when i try to load it

krodelabestiole@mini-crash:~$ jackd -R -P70 -p128 -dfirewire -dhw:0 -r48000 -p64 -n3 -i8 -o8
no message buffer overruns
jackd 0.116.1
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

JACK compiled with System V SHM support.
loading driver ..
00776227469:  (ffado.cpp)[  92] ffado_streaming_init: libffado 1.999.40- built Feb 24 2009 00:53:39
libiec61883 warning: Established connection on channel 0.
You may need to manually set the channel on the receiving node.
libiec61883 warning: Established connection on channel 1.
You may need to manually set the channel on the transmitting node.
firewire ERR: Could not start streaming threads: -1
DRIVER NT: could not start driver
cannot start driver
no message buffer overruns

a few seconds after it loads : firewire ERR: Could not start streaming threads: -1

http://www.ffado.org/?q=node/516 ffado says

firewire ERR: Could not start streaming threads
DRIVER NT: could not start driver
cannot start driver

Reason: This could be happening if jackd has crashed. For instance if jackd is started with a to low setting for frames/period or periods
Solution: Start gscanbus and select "Force Bus Reset" under "Control"

i tried gscanbus and i tried to change my settings with qjackctl but nothings works better

also still have the same problem after many jackd (0.116.2 and 0.116.1) and ffado builds

about my firewire :

krodelabestiole@mini-crash:~$ lspci | grep 1394
07:06.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller

i also tried to solve my problem using the Troubleshooting guide and deleting ParallelInstallations?

i really don't know what to do now ?

sorry for my bad english

Change History

07/12/09 18:59:12 changed by kro

i think this might be the same problem as this one /ticket/223 as i have this message

Jack crashes with firewire ERR: wait status < 0! (= -1)

with the last ffado 1.999.42

07/12/09 23:43:59 changed by kro

sorry i think it's more a nVidia kind of problem /ticket/181 like this one...

ffado works a little bit when i use nv but i still have plenty of xruns and jackd crashes very often often. still not usable this way.

krodelabestiole@mini-crash:~$ lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300] (rev a1)

i have no access to PCI latency timer setup in the bios.

09/22/09 14:52:13 changed by arnonym

Hi,

could you try without -P70 and with something higher than 3x64 for buffers? translating from freebob 3x64 becomes ~ 3x128 in ffado. Using 3x64 in ffado is _really_ pushing your luck.

11/21/09 12:16:32 changed by ppalmers

  • status changed from new to closed.
  • resolution set to worksforme.

Seems to be fixed for the original poster.