Ticket #234 (closed bug: fixed)

Opened 5 years ago

Last modified 5 years ago

JACK 2 doesn't use the standard system port names

Reported by: das Assigned to: adi
Priority: major Milestone:
Component: Version: FFADO SVN (trunk)
Keywords: Cc:
The device the bug applies to:

Description

Running JACK 2 with FFADO, the hardware input/output ports are named like system:AP0_dev0_Unknown etc., instead of the usual system:playback_1 etc. as with JACK 1 (or JACK 2 with the ALSA backend).

Apparently the standard port names don't exist even as aliases, so this breaks anything that expects these port names to be present (e.g. Ardour sessions created with JACK 1).

Apart from that, the port numbering is highly inconsistent and confusing: system:AP0_dev0_Unknown system:AP1_dev0_Unknown0 system:AP2_dev0_Unknown1 system:AP3_dev0_Unknown2 etc.

Attachments

ffado-portaliases.patch (1.5 kB) - added by adi on 02/06/10 06:57:09.

Change History

09/22/09 14:34:22 changed by arnonym

  • milestone changed from FFADO 2.0 to FFADO 2.x.

Jack2 is not a target for the 2.0 release...

09/25/09 07:18:08 changed by adi

This is actually a jack2 bug, and it's actually a feature, not a bug.

http://trac.jackaudio.org/browser/jack2/trunk/jackmp/linux/firewire/JackFFADODriver.cpp, around line 500, there's the port naming.

With my Alesios io14, I get names like something_ADAT4, and that's much better than simply system:playback27, because I directly know which port is the right one.

In other words: in the future, everyone would have this naming scheme. (and if the ALSA guys would have a naming vector, they'd probably go for it, too). I agree one could set a port alias, but that's easy to fix. Let me see...

I (personally) don't know why your channels are not named, mine are pretty useful (ADAT1-8, SPDIF-L, SPDIF-R, Main-Out and so on).

02/06/10 06:57:09 changed by adi

  • attachment ffado-portaliases.patch added.

02/06/10 06:59:16 changed by adi

  • owner set to adi.
  • status changed from new to assigned.
  • milestone deleted.

The attached patch fixes this issue. If nobody objects, I'll submit it to the jackd2 guys and close this ticket once the patch hits their repository.

02/10/10 12:17:18 changed by adi

  • status changed from assigned to closed.
  • resolution set to fixed.