Ticket #238 (closed enhancement: duplicate)

Opened 11 years ago

Last modified 10 years ago

M-Audio ProFire 610 support

Reported by: adi Assigned to: arnonym
Priority: trivial Milestone: FFADO 2.1
Component: Version: FFADO SVN (trunk)
Keywords: Cc: smartattack@gmail.com
The device the bug applies to:

Description

Pete Morgan has provided a patch on the mailing list to enable ProFire? 610 support in the trunk. It's a DICE device, so basic support can be added by applying the attached patch.

It would be good to update the device database von www.ffado.org, too. (change the status from unknown to Experimental)

Attachments

profire-610.patch (505 bytes) - added by adi on 10/11/09 08:45:37.
debug.tar.gz (19.6 kB) - added by daniele on 08/09/10 02:54:04.

Change History

10/11/09 08:45:37 changed by adi

  • attachment profire-610.patch added.

10/12/09 14:03:47 changed by arnonym

  • status changed from new to assigned.
  • owner set to arnonym.

Merged into trunk in r1687.

Can someone also confirm that the mixer works too?

06/06/10 00:53:57 changed by pdhales

Will this update help with a driver for the profire 2626?

07/21/10 10:22:04 changed by adi

  • status changed from assigned to closed.
  • resolution set to fixed.

I'm closing this ticket. If anybody is interested or has problems with mixer support, feel free to reopen it.

Successful report of a working mixer would also be nice, so we can mention it in the device database.

08/09/10 02:54:04 changed by daniele

  • attachment debug.tar.gz added.

(follow-up: ↓ 5 ) 08/09/10 03:39:20 changed by daniele

  • status changed from closed to reopened.
  • resolution deleted.

I'm reopening this ticket since I wasn't able to get Jack playback using this device, while capturing works as expected.

I attached debug logs, using the new firewire stack.

A few notes that may be of interest:

  • using the old stack I wasn't even able to start jackd - even ffado-test ListDevice hung and showed incomplete information (before you ask: permissions on /dev/raw1394 were right);
  • I had some success in setting the mixer to "Generic_Dice_EAP" and using it: I could route analog input to output, hear and even mix it, but still silence from Jack;
  • I tried dual-booting as suggested here for the M-Audio Ozonic, but then could not start jackd - I would argue it isn't the same muting issue, since I experienced analog output (see the previous note); instead I could see mixing and routing defaults as set under Windows: I reproduced them after power-cycling the device, with similar results: analog input is monitored, Jack is not.

(in reply to: ↑ 4 ) 08/09/10 06:16:30 changed by stefanr

Replying to daniele:

I'm reopening this ticket since I wasn't able to get Jack playback using this device, while capturing works as expected.

I attached debug logs, using the new firewire stack.

This is most certainly not a ProFire 610 specific problem but one that apparently affects all DICE based devices with EAP if ffado is run on firewire-core instead of raw1394. Saffire Pro24: works on old kernel drivers, silent on new kernel drivers

A few notes that may be of interest:

* using the old stack I wasn't even able to start jackd - even ffado-test ListDevice hung and showed incomplete information (before you ask: permissions on /dev/raw1394 were right);

Impossible to say on this basis whether this point is ProFire 610 related. Maybe the controller (Ricoh R5C832 according to your ffado-diag output) acted up.

* I had some success in setting the mixer to "Generic_Dice_EAP" and using it: I could route analog input to output, hear and even mix it, but still silence from Jack;

* I tried dual-booting as suggested here for the M-Audio Ozonic, but then could not start jackd - I would argue it isn't the same muting issue, since I experienced analog output (see the previous note); instead I could see mixing and routing defaults as set under Windows: I reproduced them after power-cycling the device, with similar results: analog input is monitored, Jack is not.

These two points are consistent with my observations with Focusrite Saffire Pro24, another DICE device with EAP. (Dual-booted with OS X though, not Windows.)

09/05/10 11:13:21 changed by arnonym

  • status changed from reopened to closed.
  • resolution set to duplicate.

The playback thing is a problem all dice-based devices that implement the EAP seem to have. Nothing ProFire? 610 specific. and its being worked on...

I created #301 as reference for that.

Thanks for reporting the mixer, I added the generic line in r1884.