Ticket #251 (closed bug: worksforme)

Opened 11 years ago

Last modified 11 years ago

Motu 828 mk will only run at 96khz

Reported by: pdhales Assigned to: jwoithe
Priority: major Milestone: FFADO 2.1
Component: Version: FFADO SVN (trunk)
Keywords: Cc:
The device the bug applies to: MOTU 828mk2

Description

If I try to set it to 44.1, it pretty much locks up my system. Tried 2.0.0 and svn - both with the same result. :(

Change History

01/06/10 14:21:59 changed by jwoithe

  • owner set to jwoithe.

Thanks for your report. I need a few more pieces of information to move forward on this.

The subject says "Motu 828 mk will only run at 96kHz". There seems to be a number missing after the "mk" (possibly a typo). That number is important - could you tell me which 828 it is that you have?

Also, could I have a few more details about your system? For starters:

  • what distribution have you installed?
  • What kernel is running (the output of "uname -a" will do nicely here)?
  • what firewire card is in the computer (run "lspci -v" and report the section associated with the firewire card)
  • what command line is being used to start jackd?
  • if using qjackctl, which version is in use?

Finally, could you describe in more detail what is meant by "pretty much locks up my system"? For example, can you still move the mouse and have the mouse pointer move? What do you find you need to do to get control back?

Presumedly you've tried this at 96 kHz and had it work. Does 88.2 kHz work? What about 48 kHz?

01/06/10 14:40:11 changed by pdhales

Some quick notes - I am at work and won't be near the unit for a while:

  • it's a mark 2 (aka II)
  • OS is fedora 10
  • The firewire card is a via based pcmcia one
  • I have tried quite a few jackd commands and options though qjackctl, all much the same result but will provide some further detail when I am back at the machine

With regards to the lockups, somtimes the mouse still moves but I think I am getting about 1 frame every 3 seconds. Other times the laptop completely freezes. If the laptop does not freeze it comes back to life after about 1 minute.

With regards to sample rates, I have generally stuck with 96khz because it seems to work. From memory 88.2 was OK, but I haven't bothered with it. 44.1 and 48 both cause serious problems. :(

01/06/10 14:48:22 changed by pdhales

When I first started running the unit, I would just use:

jackd -d firewire

Which caused the freeze issue. I think surmised (incorrectly) that the unit was not supported under linux. For some reason I plugged it in a week or two later and tried it at 96 khz and to my surprise it worked...

01/06/10 15:08:47 changed by jwoithe

  • device_name set to MOTU 828mk2.

Yes, I'm at work too so have limited scope to respond until later in the day (which timezone are you in?). Thanks for the additional information. Here are a few thoughts.

Firstly, VIA-based controllers are a mixed bag (see http://subversion.ffado.org/wiki/HostControllers). However, the issue you're seeing doesn't have all the hallmarks of a controller issue so I'm inclined to leave that in the background for the moment.

The reported mouse movement is indicative of a system under heavy load. What CPU (model, speed) and RAM (size) does the system have?

I'll await the reports of the jackd commands used with interest.

Regarding the "jackd -d firewire" command, except on very recent jack snapshots this will not run with realtime privileges. This may have something to do with the symptoms, especially the regular glitches reported in #250.

To get some sort of benchmark, when you get home could you please try a command line like this:

  jackd -R -P70 -d firewire -p 1024 -n 4 -r44100

and see what happens? If you get no joy from within qjackctl please try by just typing this command into a shell. There has been one other report of "strange" FFADO behaviour which is present only when qjackctl was in use and it would be good to eliminate that in your case if possible.

01/06/10 23:10:39 changed by pdhales

The machine is a laptop with a 1.73ghz celeron cpu and 1 gigabyte of ram.

01/06/10 23:31:08 changed by jwoithe

Hmm, ok, I would expect that machine to be plenty powerful enough. So let's concentrate on the other things.

01/06/10 23:34:16 changed by pdhales

jackd -R -P70 -d firewire -p 1024 -n 4 -r44100

Locks up the laptop completely - I get a line or two of output and then a complete lockup. :(

01/07/10 02:35:13 changed by jwoithe

Something really isn't right somewhere - that behaviour is very strange. The line or two of output you get - I presume that's just the opening banners of jackd and so forth. It may be instructive to try

  jackd -R -P70 -d firewire -p 1024 -n 4 -r44100 -v 5

or even with "-v 6" and see if the resulting messages (and in particular the ones immediately before the freeze) give us some clue as to what's going on.

01/17/10 14:16:34 changed by jwoithe

I'll leave this ticket open for now, but I suspect the problem we're seeing at 1x rates is related to the xruns you're seeing at 2x rates (as described in ticket #250). Since things "almost run" at 2x rates we'll concentrate on #250 for now and revisit #251 on an as needs basis later.

01/17/10 21:05:58 changed by jwoithe

  • status changed from new to closed.
  • resolution set to worksforme.

As per comment:16:ticket:250, original reporter does not have access to the hardware at present. The suspicion of the root cause of these issues rests on a card reader which shared the same IRQ as the firewire interface. Testing by the reporter will be done when the opportunity allows and either this ticket or #251 will be reopened if applicable.