Ticket #253 (closed bug: invalid)

Opened 11 years ago

Last modified 11 years ago

Could not communicate with the FFADO DBus service...

Reported by: cedricr Assigned to:
Priority: blocker Milestone: FFADO 2.1
Component: Version: FFADO SVN (trunk)
Keywords: Cc: cedric.rouzeaud@free.r
The device the bug applies to:

Description

I am try to use my TC Electronic Konnekt 24D with ffado-svn on Arch Linux. The 1788 version compile normally but, when I launch ffado-mixer, I have the following error message: "logginghandler: Could not communicate with the FFADO DBus service..." Could you help me, please ? Thank you for your nice application and your support.

With kind regards,

CedricR

Change History

01/09/10 12:12:31 changed by arnonym

  • status changed from new to closed.
  • resolution set to worksforme.

When you click "try again", it will try again. And as it failed the first time, it will start ffado-dbus-server itself.

In the future there will be a config file so the dbus-daemon starts ffado-dbus-server when org.ffado.Control is requested and not provided by any running service...

01/10/10 09:31:35 changed by cedricr

  • cc set to cedric.rouzeaud@free.r.
  • status changed from closed to reopened.
  • resolution deleted.

Thank you first for your quick answer. If I launch ffado-dbus-server before as it is explained in the wiki, I have this:

[cedric@Linux-LPT ffado-svn]$ ffado-dbus-server & [1] 10174 [cedric@Linux-LPT ffado-svn]$ ----------------------------------------------- FFADO Control DBUS service Part of the FFADO project -- www.ffado.org Version: 2.999.0-1788M (C) 2008, Pieter Palmers This program comes with ABSOLUTELY NO WARRANTY.


01933718622: (ffado-dbus-server.cpp)[ 270] main: Discovering devices... 01933757426: Fatal (devicemanager.cpp)[ 191] initialize: No firewire adapters (ports) found. 01933757453: Error (ffado-dbus-server.cpp)[ 277] main: Could not initialize device manager 01933757601: Debug (ffado-dbus-server.cpp)[ 202] exitfunction: Debug output flushed... no message buffer overruns

It seems there no firewire adapter found on this computer but I know that there are installed:

[root@Linux-LPT ffado-svn]# pacman -Q libraw1394 libraw1394 2.0.4-1

[root@Linux-LPT ffado-svn]# pacman -Q libiec61883 libiec61883 1.2.0-1

Could help me, please?

Thank you in advance.

CedricR

01/10/10 12:39:46 changed by arnonym

  • status changed from reopened to closed.
  • resolution set to invalid.

I am afraid this is not a bug (certainly not a "blocker") but a misconfiguration on your side.

Please take it over to the ffado-user mailing-list or try to catch one of us on irc in #ffado.

The reasons for the error are many:

  1. You might not have the old firewire-stack running.
  2. You might not have the right to access /dev/raw1394.
  3. You might have an electrical problem with the firewire connection.

PS: Coming to think of it, ffado-mixers behavior when ffado-dbus-server fails to start might be improved. (#254)