Ticket #264 (closed bug: fixed)

Opened 5 years ago

Last modified 3 years ago

jackd output flooded with ProcessAsync read errors, system get unresponsive

Reported by: fice Assigned to:
Priority: major Milestone:
Component: generic Version: FFADO SVN (trunk)
Keywords: Cc:
The device the bug applies to: Focusrite Saffire Pro 10 I/O

Description

Under heavy I/O load I sometimes get this error in jackd output:

firewire ERR: wait status < 0! (= -1)
JackAudioDriver::ProcessAsync: read error, skip cycle

Normally after this jackd just stops streaming and I can restart it, but occasionally it starts to output many such error messages making the system almost totally unresponsive, so I have to reboot with sysrq.

Have this problem with both ffado 2.0.0 and current svn trunk.

Change History

01/26/10 01:17:52 changed by adi

Could it be that you're on jackd2 (jackdmp)? I also see this behaviour with my io14, but not on jackd1. On jackd1, I get an xrun, and that's it, on jackd2, it may cause the flooding you experience, though I'm still able to hit ctrl+c or close the xterm to abort it.

I think it's rather a jackd2 bug, FFADO only indicates the error condition, but jackd2 doesn't (occasionally) recover from that.

02/04/10 07:00:09 changed by fice

Yes, I use jackdmp (jackd 1.9.4).

02/05/10 13:17:15 changed by fice

After replacing jack 1.9.4 with version 0.118.0 I do not experience failures under heavy I/O load any more. I had some jack failures probably caused by graphics drivers (nvidia), but no flooding. By "failures" I mean not xruns but situations when jackd need to be restarted to recover.

09/12/10 07:43:01 changed by gauss-gs

Looks like #304 is the same or related issue.

06/24/11 08:34:11 changed by fice

I am still able to reproduce the flooding problem on VIA VT6306 controller using the latest FFADO from svn and stock Fedora 15 kernel (2.6.38.8-32.fc15.x86_64) with the new firewire stack.

After replacing the VIA controller with NEC uPD72874 the flooding does not happen any more. FFADO still does not always recover from xruns: jackd continues to run but all outputs become silent until I restart jackd.

03/27/12 07:17:46 changed by adi

Is it still valid with current jackd2? If not, please close the bug.

05/04/12 04:17:07 changed by jwoithe

  • status changed from new to closed.
  • resolution set to fixed.

Based on comment 5 it seems that at least part of the problem is due to the Firewire controller originally being used. Without feedback about recent jack2/libffado performance I'll close this ticket as "fixed". If subsequent testing shows that there is still an issue it can be re-opened.

Ticket 304 (as noted in comment 4) seems to be dealing with a similar but not identical problem. As of this writing, #304 remains open pending further feedback.