Ticket #269 (closed bug: worksforme)

Opened 5 years ago

Last modified 3 years ago

Could not start streaming threads with Saffire PRO 24

Reported by: yves.g Assigned to: arnonym
Priority: major Milestone:
Component: generic Version: FFADO SVN (trunk)
Keywords: streaming Cc:
The device the bug applies to: Focusrite Saffire PRO24, Echo Audiofire Pre8

Description

I am using ffado SVN (trunk). Compilation and installation went OK, my device is recognized (e.g. with "ffado-test Discover) but jackd fails with error:

firewire ERR: Could not start streaming threads: -1
DRIVER NT: could not start driver
cannot start driver

My system is ubuntu lucid beta1 (I upgraded from ubuntu hardy with the hope that it would solve the problem with ffado, but it did not).

Attachments

saffire24logs.tar.gz (16.6 kB) - added by yves.g on 04/04/10 06:31:44.
Logs (ffado.log for jackd command, and ffado-diag.log for ffado-diag command)

Change History

04/04/10 06:31:44 changed by yves.g

  • attachment saffire24logs.tar.gz added.

Logs (ffado.log for jackd command, and ffado-diag.log for ffado-diag command)

04/10/10 10:39:56 changed by yves.g

  • owner changed.
  • component changed from generic to devices/dice.

04/22/10 04:43:43 changed by yves.g

I rebuilt with revision 1814, and checked again. The same error still appears but randomly. I could successfully start jackd at 44100, 48000, 88200 and 96000, despite the fact that it often fails.

I am pursuing my tests...

06/06/10 09:50:42 changed by yves.g

Now with revision 1846, it fails very often (95% of trials fail). There remains a process ffado-dbus-serv still running after jackd stopped. Could the problem be there?

06/06/10 10:11:12 changed by arnonym

  • owner set to arnonym.
  • status changed from new to assigned.

(I am currently stumped but will look at this the next days.)

ffado-dbus-server has very little to do with running jackd. jackd will not be influenced when a ffado-dbus-server is running (hopefully). And it will definitely not start or stop a ffado-dbus-server. So that is not the problem. Probably ffado-dbus-server is still running because you started ffado-mixer some time before.

You should try without running ffado-mixer before (or after killing ffado-dbus-server with killall ffado-dbus-server) to exclude influences there. But I doubt that this is the problem.

06/06/10 11:16:54 changed by yves.g

I think I tried any possible configuration:

* with/without launching ffado-mixer first

* with/without killing ffado-dbus-server

* with all possible sampling rates in command jackd -d firewire -r xxxxx

08/17/10 07:28:51 changed by yves.g

  • component changed from devices/dice to generic.
  • device_name changed from Focusrite Saffire PRO24 to Focusrite Saffire PRO24, Echo Audiofire Pre8.

I wonder if this bug is tied with the Saffire Pro 24. I installed ffado svn (rev. 1881) on another PC (under Ubuntu Lucid Lynx 10.4) and I observed the same behaviour, whereas the audio interface is Echo Audiofire Pre8. When I try to start jackd, I may get three results: 1) failure with the same message as above:

loading driver ..
07498144881:  (ffado.cpp)[  92] ffado_streaming_init: libffado 2.999.0-1881 built Aug 17 2010 10:14:14
firewire ERR: Could not start streaming threads: -1
DRIVER NT: could not start driver
cannot start driver
no message buffer overruns

2) failure with the following message

no message buffer overruns
JACK compiled with System V SHM support.
loading driver ..
07321122251:  (ffado.cpp)[  92] ffado_streaming_init: libffado 2.999.0-1881 built Aug 17 2010 10:14:14
jackd watchdog: timeout - killing jackd
Abandon

3) success: jack starts without error and I can use it for some time (usually tens of minutes) before it breaks.

I change the component for Dice to Generic.

09/16/10 12:55:50 changed by arnonym

I took a look at your ffado.log, the only strange thing I could see was that something went wrong in the run before. Therefor ffado is complaining

07321880031: Error (dice_avdevice.cpp)[1305] startStreamByIndex: ISO_CHANNEL register != 0xFFFFFFFF (=0x00000001) for ATX 0

That means that the computer had started streaming before and registered itself as the owner. But now it expects no owner on the stream. When ffado fails with that error, you have to generate a bus-reset either by running ffado-test BusReset or by disconnecting the firewire cable or by power-cycling the device.

09/16/10 13:28:20 changed by adi

Things might be slightly improved with r1900. The dice restart patch addresses this ISO_CHANNEL discrepancy, so chances are that it'll work even without a bus reset.

I've been successfully restarting jackd with the restart patch for several months now, so I encourage the ticket author to try current svn trunk.

09/17/10 14:39:42 changed by yves.g

Sorry, I could not test earlier, since I had no access to my Saffire Pro 24.

With revision 1900, it works much better. I may still get the error:

firewire ERR: Could not start streaming threads: -1

but it occurs less often.

Moreover, when I tried to start again after this failure, jack started correctly in all the trials.

09/18/10 11:13:00 changed by yves.g

I have to contradict what I said in my previous comment.

I made a more complete series of tests. In each trial, jack was started with the command

jackd -d firewire -r 44100

Out of 20 trials, 5 led to the same error, whereas 15 were successful. The first trial was a failure, but the second trial permitted to launch jack successfully. I stopped and restarted jack 5 times without problem, then the 4 next trials failed.

After the first of these four failures, I tried to restart jack directly, and it failed. I then switched the Saffire Pro24 off and on, but jack did not start. Once again I switched the box off and on, but again jack failed. It is only when I switched the box off and on for the third time that it finally started.

To summarize: my opinion is that r1900 does not solve the problem.

03/27/12 06:57:45 changed by adi

  • status changed from assigned to closed.
  • resolution set to worksforme.

Pro24 is known to work. Since this is an old ticket, I'm closing it.