Ticket #272 (closed discussion: fixed)

Opened 10 years ago

Last modified 8 years ago

ubuntu minimal, ffado dbus server, dbus-launch

Reported by: malo Assigned to: arnonym
Priority: trivial Milestone:
Component: generic/dbus Version: FFADO 2.0.0
Keywords: Cc:
The device the bug applies to:

Description

hi to all. i started from a minimal install CD of karmic to get my light audio server based on mpd and a firewire device (echo). device is correctly detected on ffado test list devices. kernel module 1394, permissions and so on, all done. i think to have installed all the stuff, even dbus-launch, which is part of X11 package, but when i start ffado-dbus-server i get an error from dbus-launch: Auto launch error: X11 initialization failed. any dep to satisfy? i did not want to install the graphical server, want to handle a minimal OS, how could i fix this error? thanks, in advance.....

Change History

04/14/10 13:54:22 changed by arnonym

  • owner set to arnonym.

I think this means that there is no dbus-daemon in your session running. and dbus-launch couldn't start one.

There are several solutions:

  • start a dbus daemon by hand and take care that the environment-variables point to it.
  • install the needed packages from x11. its only some libs, no big apps and no complete x-environment. The advantage is that you will be able to login via ssh with x-forwarding to run ffado-mixer. And you can setup a vncserver to run the mixer locally.

04/16/10 03:43:56 changed by malo

thank you very much for helped me. the second solution would be the one, but which are the needed packages? i tried to start ffado from a script in /etc/init.d with the request of starting dbus as user i autologin to machine as, cause i want ffado server, jackd and mpd to autostart at boot:

#
### BEGIN INIT INFO
# Provides:          ffado dbus server
# Required-Start:    dbus
# Required-Stop:
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
# Short-Description: init-Script for ffado dbus server daemon
### END INIT INFO
#

set -e

# Defaults
PATH=/sbin:/bin:/usr/sbin:/usr/bin
NAME=ffado-dbus-server
DAEMON=/usr/bin/ffado-dbus-server
PIDFILE="/var/run/ffado-dbus-server.pid"
USER=

test -f /etc/default/ffado-dbus-server || exit 0
. /etc/default/ffado-dbus-server

if [ ! "x$START_DAEMON" = "xyes" -a ! "$1" = "stop" ]; then
	echo "Edit /etc/default/ffado-dbus-server to start ffado-dbus-server"
	exit 0
fi

test -f $DAEMON || exit 0

. /lib/lsb/init-functions

case "$1" in
	start)
	        log_begin_msg "Starting ffado-dbus-server"
		start-stop-daemon -m -b -S -q -p $PIDFILE -x $DAEMON -u $USER
		;;
	stop)
	        log_begin_msg "Stopping ffado-dbus-server"
		start-stop-daemon -K -q -p $PIDFILE -n $NAME -u $USER
		rm -f $PIDFILE
		;;
	restart)
		$0 stop
		sleep 1
		$0 start
		;;
	*)
		log_warning_msg "Usage: /etc/init.d/ffado-dbus-server {start|stop|restart}"
		log_warning_msg "  start - starts ffado-dbus-server service"
		log_warning_msg "  stop  - stops ffado-dbus-server service"
		log_warning_msg "  restart - starts a new ffado-dbus-server service"
		exit 1
		;;
esac

exit 0

but no way. i tried to start manually in console dbus before starting ffado-dbus-server but no way. clearly my fault, i did not find on google a solution neither understood how this demons work..... sorry for posting here, but i thought it was a problem of some dependency not cleared for ffado-server...

04/27/10 14:56:12 changed by arnonym

  • status changed from new to assigned.

if you are running a non-gui, no-mixer-needed minimal version, you might be interested in r1816.

Would that help you?

Otherwise I think that the package dbus-x11 contains dbus-launch. Please see its man-page how to use it correctly in your case. Making your init-script depend on dbus only makes it depend on the system-bus of dbus while ffado only uses the session-bus. Might be an idea to switch that sometime in the future...

03/28/12 03:50:14 changed by jwoithe

Arnold: is there any need to keep this ticket open anymore?

05/01/12 04:30:17 changed by jwoithe

  • status changed from assigned to closed.
  • resolution set to fixed.

It seems that this issue can be considered fixed.