Ticket #282 (closed bug: fixed)

Opened 10 years ago

Last modified 8 years ago

KeyError: dbus.String(u'')

Reported by: juanramon Assigned to: arnonym
Priority: minor Milestone: FFADO 2.x
Component: ffado-mixer Version: FFADO SVN (trunk)
Keywords: Cc:
The device the bug applies to:

Description

When I run ffado-mixer I get the next error message:

Traceback (most recent call last):

File "/usr/lib/python2.6/site-packages/ffado/widgets/crossbarrouter.py", line 176, in updateLevels

print self.switchers[peak[0]].peakValue(peak[1])

KeyError?: dbus.String(u)

I dont know how much relevant it is...

Change History

05/14/10 01:02:46 changed by juanramon

KeyError?: dbus.String(u)

05/14/10 01:39:12 changed by juanramon

I get this message when I click VuMeters? button on.

10/28/10 09:09:57 changed by juanramon

Maybe it can help you. This message is sent when I click the vu button on.

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/ffado/widgets/crossbarrouter.py", line 176, in updateLevels
    self.switchers[peak[0]].peakValue(peak[1])
KeyError: dbus.String(u'')

10/28/10 09:58:23 changed by arnonym

Can you tell us which version of python, python-dbus and pyqt4 you have installed?

But it is strange that there seems to be an empty string sent around...

10/28/10 16:27:28 changed by juanramon

python 2.6.5 pyqt4 4.7.2 python-dbus 0.83.0 dbus 1.2.16

I remember a lot of revisions ago (maybe more than one year) it worked ok. but now it doesn't and I don't konw why I have tried to follow the code but it is cryptic for me. :)

10/28/10 22:31:21 changed by juanramon

I'm thinking maybe is a problem about interface, before I own a Phonic HelixB FW but now I have got a Focusrite PRO 40 Could that be the problem of an empty string sent to dbus??

03/27/12 07:05:40 changed by adi

Is this bug still valid? Otherwise, we'd like to close it.

03/28/12 03:55:03 changed by jwoithe

To prove the point, all we really need is for this to be tested by someone who has a device which includes the crossbar router in its ffado-mixer panel. Click on the "VU button" and see if the python crash happens.

Unfortunately none of my devices utilise this widget in their mixer panel; otherwise I'd run the test myself.

04/07/12 05:20:12 changed by jwoithe

Can someone with a device which uses the crossbar router in ffado-mixer please run ffado-mixer and click on the "VU button" therein? I think this applies to any DICE device. Does python crash? If not then this ticket is more than likely no longer valid and can be closed with a reasonable degree of confidence. If there are no tests within a week or so I think we'll still close the ticket but the confidence level won't be quite so high.

04/11/12 16:52:31 changed by jwoithe

  • status changed from new to closed.
  • resolution set to fixed.

From Yves Grenier via the ffado-devel mailing list:

Yes, the crossbar router is part of ffado-mixer for the Saffire Pro24.

But I see no "VU button" in the crossbar router. I only see a button labeled "Switch peak meters". When I click on this button, nothing happens, and jackd does not stop. I do not see any peakmeters in ffado-mixer. If this makes reference to the LEDs on the Saffire Pro24, then it has no effect on these LEDs.

Can someone tell me what is supposed to be the effect of this button? Could this button be an old trick to bypass the bug that existed with these LEDs some time ago (ticket #347 solved by r2098)?

As far as I understand, ticket #282 may be closed.

Given this test result from Yves I'll close this bug as "fixed". If it can be recreated using SVN trunk it can be re-opened.

We do need to qualify what the "switch peak meters" button is meant to do. Can anyone help with that? If it is indeed a leftover relic from times past it should be removed.