Ticket #286 (closed feature: invalid)

Opened 10 years ago

Last modified 9 years ago

OXFW970 device support: LaCie FireWire Speakers, Griffin FireWave

Reported by: stefanr Assigned to:
Priority: minor Milestone:
Component: devices/oxford Version: FFADO SVN (trunk)
Keywords: Cc:
The device the bug applies to:

Description

I attempted to get the following two OXFW970 based devices working without success:

  • LaCie FireWire Speakers (stereo output device)
  • Griffin FireWave (stereo or 5.1 output device; 5.1 might possibly involve vendor specific AV/C commands)

These are consumer-grade devices. LaCie FireWire speakers have a terrible sound quality (tried on Mac OS X), and Griffin FireWave is no longer being produced. The only benefit of getting them working would be that I would have dummy devices in addition to my BeBoB based device, to test a multi-device setup in kernel driver maintenance. (I guess I better get another fully supported device for that purpose.)

I am opening a single ticket for both devices because they are both based on the same chip and the failure mode of ffado is the same.

I added the following two sections to /usr/local/share/libffado/configuration:

{
    vendorid = 0x00001292;
    modelid = 0x000f970;
    vendorname = "Griffin";
    modelname = "FireWave";
    driver = 4;
},
{
    vendorid = 0x0000d04b;
    modelid = 0x0000f970;
    vendorname = "LaCie";
    modelname = "FireWire Speakers";
    driver = 4;
},

I also tried driver = 3 and got a different failure then (no Music subunit detected, I think).

I'll attach verbose logs from jack 0.118.0 + ffado trunk r1846, libraw1394 2.0.5, firewire-core/-ohci on kernel 2.6.34.

Attachments

firewave.log (364.5 kB) - added by stefanr on 06/06/10 09:29:57.
log from "jackd -dfirewire -v9" with griffin firewave attached
speakers.log (311.0 kB) - added by stefanr on 06/06/10 09:31:33.
log from "jackd -dfirewire -v9" with lacie speakers attached
firewave.config_rom.txt (2.0 kB) - added by stefanr on 06/06/10 09:33:36.
configuration ROM dump of griffin firewave
speakers.config_rom.txt (2.0 kB) - added by stefanr on 06/06/10 09:34:16.
configuration ROM dump of lacie speakers

Change History

06/06/10 09:29:57 changed by stefanr

  • attachment firewave.log added.

log from "jackd -dfirewire -v9" with griffin firewave attached

06/06/10 09:31:33 changed by stefanr

  • attachment speakers.log added.

log from "jackd -dfirewire -v9" with lacie speakers attached

06/06/10 09:33:36 changed by stefanr

  • attachment firewave.config_rom.txt added.

configuration ROM dump of griffin firewave

06/06/10 09:34:16 changed by stefanr

  • attachment speakers.config_rom.txt added.

configuration ROM dump of lacie speakers

06/07/10 08:36:48 changed by dajt

I have a Griffin FireWave?, and I've watched my Mac Mini (PowerPC) talk to it with voyeur (my hacked version of nosy). In six-channel 24-bit PCM mode, the only command I don't know how to parse is an FCP request: 00 ff bf c0 01 00 00 00 ff ff 90 40 04 02 01 06 06. I don't have any specs that describe opcode bf. Oh, and it needs unblocked streaming data, not blocked. Other than those details, my standalone fwplay program can play sound through it without problem.

I haven't tried activating the Dolby stuff--if anything is likely to use vendor-specific stuff, that's it.

06/22/10 14:09:15 changed by dajt

One ffado bug I've noticed is that it continues to attempt to send extended plug info requests to the FireWave? even though the FireWave? replies with a subfunction of 00, which seems to be it's way of saying "I don't grok subfunction c0" ffado sends 01ff02c0 00000002 ff020000 and it replies with 0cff0200 01000001 ffado sends 01080200 ffffffff (or various other plug combinations) and it replies to them all with 0c080200 0101ffff

02/07/11 01:36:13 changed by cladisch

Dajt, if you want to test a kernel driver, here's a patch: http://marc.info/?l=linux1394-devel&m=129707012813536

04/12/11 00:09:30 changed by stefanr

  • status changed from new to closed.
  • resolution set to invalid.

This RFE is obsolete now due to availability of Clemens' ALSA driver for these devices.