Ticket #311 (closed bug: wontfix)

Opened 10 years ago

Last modified 8 years ago

Focusrite Saffire Pro 24 won't start up properly

Reported by: autostatic Assigned to:
Priority: major Milestone:
Component: devices/dice Version: FFADO SVN (trunk)
Keywords: focusrite saffire pro 24 dice Cc:
The device the bug applies to: Focusrite Saffire Pro 24

Description

When I try to run JACK for the first time after the Focusrite gets initialized JACK gets killed just a few seconds later. If I then restart JACK it starts successfully. Steps to reproduce:

  • Power off Focusrite Pro 24
  • Power it on again
  • Start JACK

This behaviour also occurs after starting up or having rebooted my PC. I'm using FFADO svn trunk revision 1881, compiled without debug option though. If that still applies in order for the devs to properly troubleshoot this issue please let me know. Also, if this has been fixed in a later revision I'd be happy to hear it. I've attached the necessary files. If more info is needed it's no problem to provide it.

I've also tested the Focusrite Saffire Pro 40 and that device doesn't show this behavior.

Best,

Jeremy

Attachments

ffado-jack-startup.tar.gz (46.2 kB) - added by autostatic on 10/21/10 07:12:52.

Change History

10/21/10 07:12:52 changed by autostatic

  • attachment ffado-jack-startup.tar.gz added.

03/06/12 05:23:56 changed by froh

I can confirm this on my laptop

AV-Linux 5.0.3
Saffire Pro 24
Builtin firewire:
Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller
libffado Version: 2.0.99+svn1995-3
jackd Version: 1:0.121.3avlinux-1


jackd output is normal, but after a few seconds:

firewire ERR: Could not start streaming threads: -1
DRIVER NT: could not start driver
cannot start driver
jackd watchdog: timeout - killing jackd
Aborted

05/11/12 05:16:29 changed by jwoithe

It's hard to know what might be going wrong here. Others have successfully used the Pro-24 with ffado, so it is possible. Having jackd killed by its watchdog means that something is concluded to be hung up. But what?

About the only thing which springs to mind is the firewire card. At least in the case of the second report the card concerned is the TI PCIxx12 chipset. Over the past month we've had some other reports from users which this card which suggest that perhaps this particular TI chip isn't behaving in the way we would like. It's early days yet, but it's worth noting. We also don't know the chipset in use by the original reporter; if it was something different then that would tend to rule out the firewire card.

To progress this further we'll need some further information. Please run ffado-diag and post the results. If possible and feasible, please update to the latest svn first since the latest ffado-diag version has a few new items which may be useful here.

Another thing to do would be to run jackd with ffado debugging turned on. Assuming it's been enabled at FFADO compile time, you simply need to add a "-v X" anywhere after "-d firewire" on the jackd command line. Since we don't really know what we're dealing with yet, perhaps make X equal to 6 initially. It'll produce a lot of output, but hopefully it'll give us some clues.

06/01/12 04:15:38 changed by jwoithe

  • status changed from new to closed.
  • resolution set to wontfix.

It's not possible to progress this further without the additional information requested in comment 2. I'll therefore close this ticket as "wontfix" for the moment. If the testing as described can be done at some future time then feel free to re-open this ticket in order to report it.