Ticket #325 (closed bug: fixed)

Opened 7 years ago

Last modified 6 years ago

Problems with ffado-mixer routing tab and Saffire PRO40

Reported by: darkbasic Assigned to: arnonym
Priority: major Milestone:
Component: ffado-mixer Version: FFADO SVN (trunk)
Keywords: Cc: nils
The device the bug applies to: Focusrite Saffire PRO 40

Description

I can't map inputs and outputs to the mixer using the routing tab.

In Windows I mapped analog input 1 to mixer input 1, analog input 2 to mixer input 2, ..., DAW 1 to mixer input 17 and DAW2 to mixer input 18. In the routing tab I expected to see 1394:0 and 1394:1 in mixer:16 and mixer:17 and that's what I found, but if set them to "disconnected" they remain still mapped! I also expected to find "analog input 1" in mixer:0 [etc.] but instead I found "disconnected"! Why? How does ffado mixer maps analog inputs to mixer inputs?

In Windows I also mapped mixer output 1 to analog output 1, mixer output 2 to analog output 2, etc... Where are these mappings in the ffado-mixer routing tab?

Also, as soon as I touch something in the ffado-mixer routing tab peak meters stop working, even if I revert the modifications I made :/

I use latest ffado and lib1394 snapshots with the new firewire stack and kernel 2.6.38. OS is gentoo amd64 with pro-audio overlay.

Change History

04/09/11 04:44:02 changed by nils

  • cc set to nils.

04/10/12 06:28:07 changed by jwoithe

I suspect that at least some of these difficulties are worked around by r2109 and r2110. If possible could you please re-test with a recent SVN snapshot and report your observations? It may be that those changes are sufficient to close this ticket, but if not it would be good to know what exactly still needs to be done.

04/10/12 16:41:32 changed by jwoithe

From Philippe Carriere via the ffado-devel mailing list:

I think this bug was prior to r2060 for which router becames available for PRO 40 and 24.

The initial report certainly predates r2060 (and the commits immediately before it, in which the actual router work was done), which would suggest that the issue is most likely resolved. It would be good if the original reporter ("darkbasic") could re-test with the latest SVN trunk and report back so we know that their particular issues have all been fixed. In the absence of information information to the contrary after 1-2 weeks this bug can probably be closed on the assumption that all is well.

04/11/12 05:25:10 changed by nils

Here are my observations with ffado-mixer from SVN r2117:

The router seems to work in general for me now, but it seems inputs and outputs have been swapped without swapping the mixer table rows and columns, i.e. formerly there were 18 inputs as columns and 16 outputs as rows on the mixer, now the inputs are rows and the outputs are columns, but they are still 16 and 18 respectively. After using the new ffado-mixer, the 2 right-most columns contain garbage values and channel 17 is mapped to an "invalid" output (which is obviously missing from the router).

See these screenshots:

Trunk/r2117: http://i.imgur.com/1UoJx.png

ffado-2.1.0-0.7.20111030.svn2000.fc16.x86_64, apparently from r2000 (started after the above with a bit of leftover garbage?): http://i.imgur.com/zQpc3.png

When I change routing, the labels in the mixer tab don't change, I have to restart the GUI to get correctly labeled inputs and outputs.

Also, as in the original report, on 48kHz the LED VU meters don't work for me, but when I switch to 96kHz they do. I haven't changed anything on the router there yet... a) I don't dare breaking it there as well and b) output to the interface only works intermittently for me on 96kHz.

Is there anything else I should check?

04/11/12 17:29:30 changed by jwoithe

Thanks for testing this Nils. In response, Philippe Carriere wrote via the ffado-devel mailing list:

Apparently, you have got involved with mismatching versions of ffado-mixer, ffado-dbus-server and libffado. I (very) rapidly wrote a page at:

http://www.premiumorange.com/la-page-web-of-phil/index.php?page=P030601

including screenshots of what must appear by now.

Note that matrix-mixer channels numbering, for instance, starts now at 1, not at 0.

Since you have two co-existing ffado versions, you must take particular care for setting the right environment variables; uninstall properly (including manual erasing of some remaining ffado python scripts in the corresponding lib directory) the possible older svn revision and install the r2117 one; and manually kill the ffado-dbus-server if you test the different versions (neither ffado-mixer nor jackd stop the ffado-dbus-server).

It seems that Philippe is concerned that some of these issues are caused by running a ffado-dbus-server from one ffado revision and ffado-mixer from another. Is this possible, or is it simple misunderstanding of your latest post?

Continuing with Philippe's response:

When I change routing, the labels in the mixer tab don't change, I have to restart the GUI to get correctly labeled inputs and outputs.

This is the purpose of the new "refresh" button in the Edit menu (a rough way for this, I admit).

Could you try this new "refresh" button and let us know if it works as described by Philippe?

A final note from Philippe:

Also, as in the original report, on 48kHz the LED VU meters don't work for me ...

You will have to reset your configuration for this, by using, one first time the Focusrite firmware under Windows of Mac OS.

I did not yet write such a reset function. Note it must be reset only one time, provided you will use revision >= 2110 further. 96kHz does not work correctly, 88.2kHz does.

04/17/12 09:05:43 changed by nils

My ffado-mixer troubles indeed stemmed from mixing new libffado, new ffado-mixer but old (packaged) ffado python modules. Let's continue discussion of this on the mailing list.

04/17/12 17:40:15 changed by jwoithe

Since the history of this issue is currently contained entirely in this ticket, it's probably best that discussion continues in the ticket. Otherwise it will be harder to follow in future, especially if some key information is posted in ffado-devel and never makes it back to the ticket.

In general I have suggested (on ffado-devel) that ticket discussions are conducted from the ticket. The reason for ffado-devel being CCed from the ticket is that it alerts others to developments within the ticketing system, making it easier for them to determine whether a response from them is warranted. It essentially means that people don't have to monitor each and every ticket.

04/18/12 00:34:38 changed by nils

Since the history of this issue is currently contained entirely in this ticket, it's probably best that discussion continues in the ticket.

Oh, I was just referring to the side issue of me mixing up stuff old and new. A far a I'm concerned, the only remaining issue is that of the broken LED meters, but that may be just another side issue as well.

05/01/12 05:11:13 changed by jwoithe

With the recent round of changes, has the subject of this ticket been resolved? Are there still issues with the LED meters which we know how to resolve and just need the time to do so? Philippe?

05/01/12 17:10:50 changed by jwoithe

  • status changed from new to closed.
  • resolution set to fixed.

From Philippe on ffado-devel:

routing tab issue was solved by the first changes I submitted. LED meters issue has been solved by the last changes I committed 2 or 3 weeks ago (I don't remember exactly), for both Pro 40 and 24. So the ticket can be considered as solved, from my viewpoint.

Thanks for your work on this Philippe.