Ticket #330 (closed bug: fixed)

Opened 9 years ago

Last modified 9 years ago

MIDI almost never incoming or at least in a really sporadic way

Reported by: orl Assigned to: adi
Priority: major Milestone:
Component: devices/dice Version: FFADO SVN (trunk)
Keywords: MIDI Jack Cc:
The device the bug applies to: Focusrite Saffire Pro 40

Description

I barely can't get MIDI in from my soundcards (Focusrite Saffire Pro 40). It might sometimes come for quite a short time (few messages), and then nothing more. It sometimes re-works without anything changed. I've tried several cables, to be sure, and have tried both cards, too. This is true with rev1969 as well as with rev1944. I've tried with only one card plugged, and it's the very same. This occurs with jackd or jackdbus. I'm using jackd-1.9.7.

Change History

04/08/11 03:58:07 changed by adi

  • owner set to adi.
  • status changed from new to assigned.

The PRO40 is a DICE device. I see exactly the same problem with my Alesis, I already thought the device was at fault, but it wasn't.

Pieter said (a couple of years ago) that MIDI functionality isn't a firmware issue but hardcoded into silicon, the DICE chip itself.

So this means we might be decoding MIDI data wrong now and then in FFADO when demuxing from the audio stream.

The decodeMidiPorts function in AmdtpReceiveStreamProcessor?.cpp is rather short, you might want to add some printfs to get more information. I'll also have a look.

Cheers

04/08/11 04:19:02 changed by damo22

On this note, When I was testing my Digidesign 003 i was unable to fully isolate the midi events from the audio events using FFADO's AmdtpProcessor?. It seemed to spit audio data down the midi channel, but i initially thought it was something I was doing wrong in my hacked code but perhaps it is a bug in FFADO's AMDTP processing code for midi data.

04/08/11 08:36:53 changed by adi

  • status changed from assigned to closed.
  • resolution set to fixed.

I hopefully fixed it in r1973, so with the cleanup, r1975 (current head) should do the trick.

At least my Alesis now shows lovely midi events with jack_midi_dump. ;)

04/08/11 14:14:56 changed by orl

I paste the changes in the rev1968 got from debian-experimental repository, and it worked perfectly with both my Saffire Pro 40. Thanks a lot!