Ticket #346 (closed enhancement: fixed)

Opened 9 years ago

Last modified 9 years ago

Changing buffer size from jack is not supported

Reported by: froh Assigned to:
Priority: major Milestone:
Component: devices/dice Version: FFADO 2.0.1
Keywords: buffer jackd Cc:
The device the bug applies to: Focusrite Saffire Pro 24

Description

When changing buffer size with jack_bufsize jackd crashes

froh@studio:~$ jack_bufsize 1024
jack_set_buffer_size(): Unknown error 4294967295

jackd log

firewire ERR: Buffer size change requested but not supported!!!
driver does not support 1024-frame buffers
  • libffado Version: 2.0.99+svn1995-3
  • jackd Version: 1:0.121.3avlinux-1

This is unfortunate because I am used to do this in my workflow, depending on if i need real time fx processing or not.

Change History

03/06/12 07:46:25 changed by adi

Confirmed.

This requires some modification on the jackd side. Right now, the corresponding function simply returns -1, hence the error code.

We would probably need to stop streaming, then set the new buffer size and later restart the streaming.

Indicating the desired buffer size to FFADO requires ffado_streaming_init(), maybe an API extension that allows to manually configure the buffer size might make sense.

03/27/12 07:01:25 changed by adi

  • status changed from new to closed.
  • resolution set to fixed.

Implemented in r2087. Requires newest jackd.