Ticket #358 (closed bug: invalid)

Opened 8 years ago

Last modified 8 years ago

System freeze when resuming from suspend-to-ram while ffado is in use

Reported by: goibhniu Assigned to:
Priority: trivial Milestone:
Component: generic Version: FFADO SVN (trunk)
Keywords: Cc:
The device the bug applies to:

Description

Steps to reproduce:

Start jack (I am using jackdbus), and suspend-to-ram. Upon resume I get a a corrupt black screen with a blinking cursor.

Work around:

Stop jack before suspend.

I can also reproduce this by starting ffado-mixer before suspend, without jack or pulseaudio running at all.

I have tried both 3.3 and 3.4 kernels.

Log message from ffado-mixer:

16:35:36 dbus: connecting to: Updated on /org/ffado/Control/DeviceManager (server: org.ffado.Control)
16:35:37 panelmanager: PanelManager::updatePanels()
16:35:37 panelmanager: going to add 00156402004988c4
16:35:37 panelmanager: Adding device 0: 00156402004988c4
16:35:37 panelmanager:  Found (00156402004988c4, 1564, FC22) Behringer FCA202
16:35:37 registration: user requested to ignore registration

I am using libffado trunk, revision: 1995

Just to be clear. This does not bother me in the slightest, I am happy that I have a work around. I thought I would create a ticket for reference, just in case anyone is interested.

I have created this package myself for the Nix package manager: http://NixOS.org so I can easily test another revision if that would be useful.

Attachments

ffado-diag.log (9.2 kB) - added by goibhniu on 07/15/12 07:45:53.
libffado-requisites.txt (6.3 kB) - added by goibhniu on 07/15/12 07:50:12.
A list of the nix "buildInputs" for libffado, this shows the versions of the relevant components on my system.

Change History

07/15/12 07:45:53 changed by goibhniu

  • attachment ffado-diag.log added.

07/15/12 07:47:37 changed by goibhniu

I should also add that I am using the free Radeon kernel module.

07/15/12 07:50:12 changed by goibhniu

  • attachment libffado-requisites.txt added.

A list of the nix "buildInputs" for libffado, this shows the versions of the relevant components on my system.

07/15/12 11:16:34 changed by stefanr

Sounds more like a kernel bug rather than a FFADO bug.

Try this: Switch from X11 to a text console (i.e. [Ctrl][Alt][F1]), log in as root, run "dmesg -n 7" in order to get kernel messages logged on the console, suspend --- while jackd or/ and ffado-dbus-server (used by ffado-mixer) is still running ---, resume, and see if any interesting messages show up.

A comparably small issue which is expected to happen is that jackd with FFADO as device driver exits with error after resume because FFADO is unable to handle IEEE 1394 bus resets.

07/15/12 16:49:16 changed by jwoithe

I agree with Stefan (stefanr) here: for the screen to be affected like you're describing it's hard to understand how FFADO could be the root cause. However, it seems that the root of the problem is at least triggered by the running FFADO (although again I can't see an immediate connection here). Please do report the outcome of the test suggested by Stefan; it might show up something interesting.

Regarding the behaviour around bus resets, some drivers at least can recover after an xrun under certain circumstances (for example, the RME driver as of r1965). However, when suspend/resume is involved there's another issue at play: prior to suspend the device itself needs to have its streaming system shut down or else it'll loose sync with the PC when the PC suddenly stops sending data. For some devices this is transparent to the user: audio simply stops. However, for others one gets strange behaviour from the interface (MOTUs, for example, will produce high-pitched noises from the outputs in this scenario). Clearly there's more to this than the bus reset and its effects. In any case, when the PC is resumed FFADO more or less needs to completely restart the streaming system in order to re-synchronise with the interface.

It would obviously be good if FFADO could arrange for this to occur transparently although I'm not sure how feasible this is right now. It's almost certainly a post-2.1 enhancement. However, before changing any of this ticket's categorisations let's wait to see whether we can obtain further details as to what's going on with your particular system.

07/16/12 12:08:11 changed by goibhniu

  • status changed from new to closed.
  • resolution set to invalid.

Thanks for the pointers and help. I suspended last night with the firewire interface disabled, JACK stopped etc. and when I tried to resume today I got the same blank screen with a blinking cursor. I think this safely rules out FFADO. I'm closing the ticket. Thanks again!