Ticket #364 (closed bug: fixed)

Opened 8 years ago

Last modified 7 years ago

Cannot turn on phantom power on Echo Audiofire4

Reported by: dlc11 Assigned to:
Priority: major Milestone:
Component: devices/fireworks Version: FFADO 2.1.0
Keywords: phantom power, audiofire4 Cc:
The device the bug applies to: Echo Audiofire 4

Description

I cannot turn on the phantom power on my Audiofire4. When I select the Phantom Power button in ffado-mixer, the log message "18:41:08 audiofire: set /PhantomPower to 1" is output, and the button stays depressed. However, the phantom power light on the audiofire does not light up, and the phantom power is not supplied to the microphone. When I select Edit -> Refresh Current Panels, the phantom power button is no longer depressed.

I have also tested with the following script, which is slightly modified from one found on ticket #136:

#!/usr/bin/ruby
require 'dbus'
bus = DBus::SessionBus.instance
ff_service = bus.service("org.ffado.Control")
ff_service.introspect
ff_manager = ff_service.object("/org/ffado/Control/DeviceManager/001486af2ef4ae91/PhantomPower")
ff_manager.introspect

ff_mixer_phantom = ff_manager["org.ffado.Control.Element.Discrete"]
print "Old value: "
p ff_mixer_phantom.getValue
puts "Setting new value 1"
ff_mixer_phantom.setValue 1
print "New value: "
p ff_mixer_phantom.getValue

When I run that script, I get the following output:

Old value: [0]
Setting new value 1
New value: [0]

I am using the newly released ffado 2.1.0. I am not sure of the firmware version (Is there a way to see this on Linux?), but I would have updated it late last October.

Attachments

takashi_af4_phantom_test.log (1.5 kB) - added by jwoithe on 09/09/13 21:50:33.
Log obtainted by Takashi when testing software phantom power switch with AF4, firmware 5.7

Change History

10/01/12 01:10:08 changed by jwoithe

It seems from all accounts that the device is not responding to the request to change the status of the phantom switch. Is this the only device control which doesn't work, or are there others?

Does the streaming component of FFADO (ie: using "jackd ... -d firewire ...") work normally? If you happen to have the firmware which doesn't play nicely with FFADO then using jackd like this will not work. That's probably the easiest way to determine the firmware status. I don't know of a way to get access to the firmware version from Linux. However, there may be a method which I'm simply not aware of due to me not having an AudioFire? device myself and therefore not having looked into the details of these devices.

Have you used earlier FFADO version(s) where the phantom switch worked as expected?

10/02/12 01:24:37 changed by dlc11

I tried some of the other controls (mutes, faders, pads) in ffado-mixer and they seem to work as expected (actually, the pad buttons seemed to work in the reverse of how I would expect -- the level of the input signal was higher when the pad button was down than when it is up, but they do toggle the setting). The "Identify Device" button doesn't seem to do anything except print "trigger /Identify" in the log messages, but I am not sure what it is supposed to do, anyway.

I am able to start jack on the device and use the line ins and line outs. I have previously used a pre-2.1.0 version of ffado based on svn revision 1913 (plus a patch to fix #233, which has since been incorporated). The behavior was the same with that version.

10/03/12 00:47:56 changed by jwoithe

Thanks for the additional information. From what you've said the whole firmware thing can be ruled out. It seems that it is just the phantom power control that's not working as it should.

Since the behaviour is unchanged since r1913 + #233 patch it's probably safe to assume that this is not a regression and instead has been present for long time (maybe even from the beginning).

A quick glance through the fireworks/ driver source suggests that phantom power is controlled via a multipurpose control as implemented by the EfcGenericIOConfigCmd object. I suspect it won't be possible to debug this problem without knowing the AudioFire? protocol in at least some detail. However, it might be worth poking around to see if anything jumps out. I may try to have a look myself, but without an AudioFire? device to test thing with and having no documentation about these devices I don't think I'll get very far. I guess we'll see. In the meantime I encourage AudioFire? owners with programming experience to look into this: even with no documentation, having a device to test against makes things much easier.

09/03/13 00:12:15 changed by dlc11

I am about 90% sure that this is a firmware issue. I finally got around to trying the audiofire with my Windows computer. I was also unable to turn phantom power on using the official Echo Firewire Console. Then I updated the firmware from 5.3 to 5.7.3, and I was able to turn phantom power on. I have not yet been able to test it with my Linux computer with Ffado. Once I do, I will update again, and hopefully this can be closed.

In any case, I think in the future I will look for interfaces with a hardware switch for phantom power and similar functions.

09/09/13 21:49:03 changed by jwoithe

Reported by Takashi Sakamoto on ffado-devel:

I bought AudioFire?4 and check this issue. The device works with firmware version 5.7. I don't update it up to 5.8 because of checking the other issues.

As a result, this bug don't appear. The device works fine in a point of getting on/off phantom power via command.

So as dlc11 said, we can judge that old firmware causes this issue. We reccomend the users to use newer firmware than 5.7, at least. Then we can close this ticket.

And I have no will to confirm which version causes this issue.

Combined with comment:4 from "dlc11", this strongly suggests that the older firmware had a bug which was preventing software control of the phantom power switch on this device regardless of platform. If "dlc11" can confirm that the new firmware fixes the phantom switch under FFADO I think we can confidently close this bug with the recommendation that users update to firmware 5.7.

I think Takashi's comment about firmware 5.8 stems from the issues raised in ticket #360. There are suggestions from the mailing list that the issue in ticket #360 may only affect the AF8 and AF12. We know the pre8 isn't affected. I don't think anyone's tested the AF4 yet. However, this is clearly a different issue (which is why there's a separate ticket).

For further reference I will attach the log provided by Takashi obtained when testing the phantom power switch.

09/09/13 21:50:33 changed by jwoithe

  • attachment takashi_af4_phantom_test.log added.

Log obtainted by Takashi when testing software phantom power switch with AF4, firmware 5.7

09/11/13 16:35:44 changed by jwoithe

Takashi Sakamoto has done some more tests and reported the following on ffado-devel:

Additionally, I test phantom power on AF4 with firmware 5.5, which is the least version with which I confirm my snd-fireworks works fine. There is no problem. I can switch phantom power via ffado-mixer. ... Users should utilize firmware version 5.5, at least for switching phantom power.

Given this, AudioFire?-4 users should ensure they have firmware 5.5 or later if they need software control of the phantom power to work.

09/24/13 17:36:37 changed by jwoithe

  • status changed from new to closed.
  • resolution set to fixed.

Takashi Sakamoto has confirmed on ffado-devel that the problem with software control of the phantom power is caused by a firmware issue, and that it also affects systems other than Linux. For AudioFire?-4 devices, users should ensure they are running firmware 5.5 or later if they wish to control the phantom power from software.

Note that the fault appears to be in the firmware, so it is not possible to work around it in software.