Ticket #39 (closed bug: fixed)

Opened 11 years ago

Last modified 11 years ago

Terratec Phase 88 FW - wrong outputport-order

Reported by: dietrich Assigned to: ppalmers
Priority: minor Milestone: FFADO 2.0
Component: Version:
Keywords: Terratec Phase88 portorder order outputport Cc:
The device the bug applies to: Terratec Phase 88 FW

Description

The order of playbackports (outputs) in jack seems to be wrong. If MPlayer plays a Stream to "plaback_0", then the physical output is sent to hardware-outputport 10. Streaming to playback_1 goes to hardware-outputport 9 and so on.

My configuration:

CPU: Intel Core2 SMP

Audio: Terratec Phase 88 FW (no other FW-Device attached)

FW-Chipset: VIA 6308P

OS/Kernel: OpenSuSE10.3 - kernel 2.6.22.5-31-default SMP x86_64

Jackd-Version: jackd version 0.107.5 tmpdir /dev/shm protocol 21

ffado-version: 1.999.6 from config.h

libraw1394-ver.:1.3.0

GCC-Version: 4.2.1 (SUSE Linux)

Thank You!

Dietrich

Attachments

dietrich_ffadodiscover.txt (33.4 kB) - added by dietrich on 10/11/07 15:20:09.
Result of "test-ffado -v5 Discover"
output_test-ffado-v5_Discover.txt.gz (66.6 kB) - added by dietrich on 10/16/07 02:03:02.
This is the output of "test-ffado -v5 Discover""
TerratecPhase88_firmwaredetails.txt (0.8 kB) - added by dietrich on 10/16/07 10:55:34.
Terratec Phase 88FW Firmware details from "src/bridgeco-downloader 0 display" - no debug build

Change History

10/11/07 15:20:09 changed by dietrich

  • attachment dietrich_ffadodiscover.txt added.

Result of "test-ffado -v5 Discover"

10/11/07 15:22:25 changed by dietrich

  • version deleted.
  • milestone deleted.

10/12/07 14:57:14 changed by arnonym

  • owner changed from had eMail contact with Pieter Palmers to ppalmers.
  • milestone set to FFADO 2.0.

This is actually a bug to be fixed for the milestone.

10/14/07 04:28:23 changed by ppalmers

  • status changed from new to assigned.

Please compile a debug version of FFADO with

scons DEBUG=1

and repeat the output of the discovery. This log does not contain the info we need.

10/14/07 04:31:50 changed by ppalmers

Is this also the case for other jack clients?

10/16/07 02:03:02 changed by dietrich

  • attachment output_test-ffado-v5_Discover.txt.gz added.

This is the output of "test-ffado -v5 Discover""

10/16/07 02:08:15 changed by dietrich

Added the output of "test-ffado -v5 Discover", but compiled with debug-messages. This is the second attachment, compressed with gzip (66.6 KB) (output_test-ffado-v5_Discover.txt.gz).

The outputport-order is not only wrong in MPlayer, this is true to other jackd-client as well.

10/16/07 09:12:27 changed by dietrich

Did some tests with all 8 outputports and multiple jack-clients today. After that, only outputport 1 and 2 are wrong. Here the portlist:

hardwareport 1 = playback_9

hardwareport 2 = playback_10

hardwareport 3 = playback_3

hardwareport 4 = playback_4

hardwareport 5 = playback_5

hardwareport 6 = playback_6

hardwareport 7 = playback_7

hardwareport 8 = playback_8

Hope this helps!

Dietrich

10/16/07 09:26:39 changed by ppalmers

Can you provide the firmware details? They can be obtained as descibed here: ObtainingFirmwareInfo

10/16/07 10:55:34 changed by dietrich

  • attachment TerratecPhase88_firmwaredetails.txt added.

Terratec Phase 88FW Firmware details from "src/bridgeco-downloader 0 display" - no debug build

11/28/07 07:46:12 changed by ppalmers

Could you verify if this is still the case with the most recent FFADO SVN trunk AND the most recent jack SVN?

11/29/07 05:09:52 changed by ppalmers

  • status changed from assigned to closed.
  • resolution set to fixed.

I can't reproduce this on my Phase88 test devices. I assume it has been fixed along the way.